Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Page 1 of 2 12 LastLast
Results 1 to 15 of 23

Thread: 94 Jimmy Help Spark

  1. #1
    Fuel Injected! ralmo94's Avatar
    Join Date
    Feb 2020
    Posts
    51

    94 Jimmy Help Spark

    Hello.

    I am trying to tune a 94 GMC k1500 5.7 4L60E.

    The problem I am having is that timing is retarded to a negative number when the throttle is hammered.

    Burst Knock is disabled.

    Minimum Retard is set to 10 deg.

    Data Log says its retarding.

    I can't seem to figure out why.

    Knock Retard not showing up

    Nor Burst knock.

    Changed low octane

    seems a little better, but data log still shows that it is retarding, when it retards there is no power. I don't understand what to change.

    I wouldn't mind if it preformed as a Non Computer HEI distributer. Am I wrong in thinking it can be programed that way?

    It has a small RV cam in it, True dual exhaust, 3.42 gears. Throttle body spacer otherwise stock

    Running open loop, trying to get ve dialed in with wide band. altered shift patterns, deleted egr.
    Thats all I can think of.

    Thanks in advance

    16196395. Service number TBI pcm
    BJLF BCC code
    Attached Files Attached Files
    Last edited by ralmo94; 3 Weeks Ago at 11:05 PM.

  2. #2
    Fuel Injected! ralmo94's Avatar
    Join Date
    Feb 2020
    Posts
    51
    forgot to add, i have searched and all I can seem to find, is people dealing with knock retard. can't seem to figure out why it is retarding, but knock retard says 0

    Thanks Again

  3. #3
    Fuel Injected! ralmo94's Avatar
    Join Date
    Feb 2020
    Posts
    51
    Incase anyone is reading this, I tried the bin I uploaded on The original post, and now I have 12 degrees advanced. ALL THE TIME! I don't know what to try next. I was thinking of downloading another bin to start from. I would real like it to just run the open throttle sa table. Nothing but the table. Without adders or retard. I don't know why I am getting 12 degrees now. When I get time this evening, I will post a data log running the above tune. And also the bin I was running while it was regarding.

    Is there any TBI $OD guys on here anymore? It would be nice to hear from someone, Even if you have no idea what it is.

    Thanks for reading.

  4. #4
    Fuel Injected! PlayingWithTBI's Avatar
    Join Date
    Dec 2018
    Age
    66
    Posts
    181
    I'd be glad to help you out but, that's too new a PCM for me, ha ha. There are a bunch of great guys with plenty of knowledge about $0D and $0E, (7427PCM?). That's all I know, keep the faith and post your log once you get it.

  5. #5
    Fuel Injected! ralmo94's Avatar
    Join Date
    Feb 2020
    Posts
    51
    Thanks for the reply. I think it's pretty much the same as 7427. From my research. Looked into tuning pretty hard before buying anything.

  6. #6
    Fuel Injected! ralmo94's Avatar
    Join Date
    Feb 2020
    Posts
    51
    I realized I may have been confusing with the bin and data log I posted in the first post. So, I renamed files with what the issue.
    I will post them now.

    Has anyone ever had an issue like this on anything? I know there are a lot of experienced tuners on here, what would you look at if you had the problem?

    I have looked at everything that I am able to edit in this bin. I have used the difference finder compared to the stock BJLF bin. I installed a new distributor when I installed the cam. It has a good cap rotor coil and plugs. New module. I really think this is not mechanical, but something in the bin. The fact that I changed something and just got a steady 12 degrees, tells me that. The thing is, that was not intentional. I don't know why it did that. I am pretty much running the stock timing table with a few degrees added. Base timing is set at 2 deg with the connector shorted, entered in the tune. I would really appreciate any ideas any one has even if it doesn't help.

    PLaying with TBI, I am guessing you tune stuff like the 7727? I know that is completely different, but what would you look for if you had something like that?

    I really appreciate these forums, I have found answers to all kinds of questions, without posting anything. I dialed in the VE pretty close, then the shotty muffler shop job came apart, and the thing breathes a lot better now. For some reason they had put a 1 -2 muffler on backwards, with dual pipes, running all the way back to the muffler. The muffler exit was only 1 3\4 inches. Once that crap fell apart, it ran a lot better even though the VE was off again. Now trying to dial in the VE again, I noticed the issue.

    I was originally contemplating switching to carb and HEI, but after reading these forums, I felt confident that I could get it running well with the PCM, and I would still need it for the transmission anyway.

    I'm sorry for such a long post, but I figured with more information, maybe someone might have an idea of something I missed or should try.

    Thanks Again. I will update here as I try other things, so if anybody else has a similar issue, maybe it will help them.
    Attached Files Attached Files

  7. #7
    Fuel Injected! ralmo94's Avatar
    Join Date
    Feb 2020
    Posts
    51
    Next thing I am trying is, I downloaded a BJLH bin, Copied my ve table, shift tables, and EGR stuff. Also disabled Burst Knock and made it open loop. On the difference tool there were a lot of unmapped differences. So, I am guessing it is something I can't see and edit?
    I suppose we will find out. I'll post another Data log after I run the new bin tomorrow
    Attached Files Attached Files

  8. #8
    Fuel Injected!
    Join Date
    Jan 2017
    Posts
    247
    What xdf are you using to mod the bin and adx are you using to log the data?
    Last edited by stew86MCSS396; 3 Weeks Ago at 09:06 AM.

  9. #9
    Fuel Injected! ralmo94's Avatar
    Join Date
    Feb 2020
    Posts
    51
    Quote Originally Posted by stew86MCSS396 View Post
    What xdf are you using to mod the bin and adx are you using to log the data?
    I had modified the ADX for using lambda

    http://www.gearhead-efi.com/Fuel-Inj...Information-0D

    I downloaded both from the 7427 info thread, along with starting bins


    Thank you
    Attached Files Attached Files
    Last edited by ralmo94; 3 Weeks Ago at 05:07 PM. Reason: added link

  10. #10
    Fuel Injected! ralmo94's Avatar
    Join Date
    Feb 2020
    Posts
    51
    Ok. Tried new bin this morning. Sounds snapier seems to run decent, BUT STILL SEEMS TO BE LOCKED AT 12! I'll post log file later. If I zero out bias values what would that do? Thank you

  11. #11
    Fuel Injected! ralmo94's Avatar
    Join Date
    Feb 2020
    Posts
    51
    Ok here is the data log, looks like its a little lean also, I guess I forgot to change stioch to 14.1. Only thing I can think of now is to try and start with stock bin again, turn egr off, and see if it retards on stock. I really don't understand why i am getting a constant 12. almost like the timing connector is pulled and set at 12.

    Thanks for looking
    Attached Files Attached Files

  12. #12
    Fuel Injected! ralmo94's Avatar
    Join Date
    Feb 2020
    Posts
    51
    Tried another Bin at lunch today. Pretty much stock BJLH, with EGR changed, VSS set, and VE table Open Loop, And Burst Knock Disabled. I have variable timing again, but still going negative, like what I would expect from burst knock. Data Log says Burst Knock is not active. I got 2 data logs of it.
    Attached Files Attached Files

  13. #13
    Fuel Injected! ralmo94's Avatar
    Join Date
    Feb 2020
    Posts
    51
    Also tried the same bin, but zeroed out the spark bias values. This resulted in a extremely high spark value and knock retard, and audible knock. I stopped and put the other chip in. zif socket sure is nice, but i forgot to stop and start the data log, so I have 1 log running both bins
    Attached Files Attached Files

  14. #14
    Fuel Injected! ralmo94's Avatar
    Join Date
    Feb 2020
    Posts
    51
    Here is a screen shot of the data log when it goes negative. I'm thinking of trying it with the temp for negative spark maxed. Don't know if I will get a chance to do another data log tonight or not, but i will post the bin.
    Attached Images Attached Images

  15. #15
    Fuel Injected! ralmo94's Avatar
    Join Date
    Feb 2020
    Posts
    51
    I just figured out how to use the edit log for the bin file

    Edit Log for BJLH Mostly Stock With EGR Delete.bin created by TunerPro.
    ************************************************** ************************
    07/09/2020 17:34:29 Scalar: Main Spark Bias changed from 9.8 deg (0x1C) to 0.0 deg (0x00).
    07/09/2020 17:34:33 Scalar: Coolant Spark Bias changed from 20.0 deg (0x39) to 0.0 deg (0x00).
    07/09/2020 17:34:38 Scalar: Altitude Spark Bias changed from 9.8 deg (0x1C) to 0.0 deg (0x00).
    07/09/2020 17:34:51 Scalar: Minimum Temperature for Negative Spark changed from 85.3 C (0xA7) to 151.3 C (0xFF).

    I'm going to return all of these settings except the last one, Minimum Temperature for Negative Spark. I guess I don't need to post the bin. I will post the data log when I have it though.

Similar Threads

  1. Spark help
    By Stokes1114 in forum GM EFI Systems
    Replies: 8
    Last Post: 08-17-2017, 02:37 AM
  2. new member, 1990 GMC Jimmy full-size
    By Tumble511 in forum Introductions
    Replies: 3
    Last Post: 03-02-2017, 04:33 AM
  3. 1994 GMC Jimmy 4.3l CPI
    By KC5UEA in forum Introductions
    Replies: 3
    Last Post: 12-10-2015, 01:41 AM
  4. 90 GMC Jimmy V1500, Conversion from TBI to MPFI
    By JimmyRon in forum GM EFI Systems
    Replies: 0
    Last Post: 10-17-2015, 08:27 PM
  5. Done with VE now onto spark
    By majacoby in forum GM EFI Systems
    Replies: 4
    Last Post: 11-14-2013, 02:14 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •