Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Page 2 of 2 FirstFirst 12
Results 16 to 19 of 19

Thread: 91 vette idle surge

  1. #16
    Electronic Ignition!
    Join Date
    Feb 2020
    Age
    37
    Posts
    16
    the car shuts off immediatly no sputter no nothing just off. when it shut off i was moving i put into neutral and coasted trying to start without going to the off position. once i cycle back to off and then try to start it will start right up. i will try to log again.

  2. #17
    Fuel Injected! 84Elky's Avatar
    Join Date
    Jul 2012
    Location
    Montgomery, AL
    Posts
    133
    Quote Originally Posted by dbstainbrook View Post
    the car shuts off immediatly no sputter no nothing just off. when it shut off i was moving i put into neutral and coasted trying to start without going to the off position. once i cycle back to off and then try to start it will start right up. i will try to log again.
    Great. Log may be helpful. In the meantime, any chance you're building up gas tank pressure in that 10-15 minutes of driving? This can happen if tank not properly vented or exit line clogged, preventing proper return flow, and it will die.

  3. #18
    Electronic Ignition!
    Join Date
    Feb 2020
    Age
    37
    Posts
    16
    i changed the map sensor and it is definetly running different. fuel is way off but got it to stall a few times in this log. doesnt stumble just off like shutting the key off. then if i open the throttle a bit it fires up.
    Attached Files Attached Files

  4. #19
    Fuel Injected! 84Elky's Avatar
    Join Date
    Jul 2012
    Location
    Montgomery, AL
    Posts
    133
    Quote Originally Posted by dbstainbrook View Post
    i changed the map sensor and it is definetly running different. fuel is way off but got it to stall a few times in this log. doesnt stumble just off like shutting the key off. then if i open the throttle a bit it fires up.
    Sorry, but it's difficult to help. Questions are asked or solutions are posed and there is no response. Specifically in Post #14: You say will not start in neutral. What about Park? P/N switch issue? Post #17: . . . any chance you're building up gas tank pressure in that 10-15 minutes of driving? This can happen if tank not properly vented or exit line clogged, preventing proper return flow, and it will die.

    Specific, detailed answers would be helpful.

    Must keep it simple. It can only be spark, a sensor, electrical or fuel.
    Spark: Coil or ICM not culprits because it immediately starts after dying indicating it's not temperature related
    Sensor: Only IAC seems strange-see below.
    Electrical: Not alternator failure because voltage excellent. You say cycling the switch helps restart, but your descriptions do not say this is every time or some of the times. Cycling the switch could trigger the fuel pump prime which leads to what appears to be the real issue - Fuel.
    Fuel (Look at the attached file):
    - IAC numbers are not right. Way too high until it dies and then way too low at times, but not consistent. The only time IAC seems correct is at key off when it goes to 160 steps. Strongly suggest checking connections and resetting IAC/TPS according to TPI procedures
    - Sample 2454, died. Car is idling. IAC steps=3. Not good.
    - Sample 5450, died. Injector PW seems to decline before dying
    - Sample 8269, died. Definite PW decline.
    Again, seems to point to tank pressure build up or a bad fuel pump failing after a bit of run-time. Pull the gas cap when it dies to check for pressure. If none, data strongly suggests fuel pump failure.
    Attached Files Attached Files

Similar Threads

  1. Tuning out cam-surge?
    By atlantadan in forum GM EFI Systems
    Replies: 4
    Last Post: 12-13-2019, 01:16 AM
  2. Cam Surge-still there.
    By Terminal_Crazy in forum GM EFI Systems
    Replies: 8
    Last Post: 04-20-2018, 12:08 AM
  3. Lean Idle Surge
    By Chewy1576 in forum GM EFI Systems
    Replies: 0
    Last Post: 12-12-2016, 03:04 AM
  4. TBI idle surge
    By Warrick in forum GM EFI Systems
    Replies: 20
    Last Post: 02-22-2016, 02:35 AM
  5. TBI idle surge
    By Warrick in forum Introductions
    Replies: 0
    Last Post: 02-14-2016, 09:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •