Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Page 3 of 3 FirstFirst 123
Results 31 to 45 of 45

Thread: GM TBI 383 $0D bad human memory need some guidance.

  1. #31
    Fuel Injected!
    Join Date
    Feb 2020
    Posts
    26
    Sorry, I downloaded it but forgot about it, and it works! Starting to suffer from CRS (Can't Remember $h*t).
    I am trying to understand what you changed to fix the issue. Looking at the file the only thing I can conclude is the change on the checksum from 0x5BB9 to 0x5F61. Is this it? If not can you explain this change and what needed to be changed to read the O2 voltage being fed into the ECU?

    Regards,
    Mark

  2. #32
    Fuel Injected!
    Join Date
    Feb 2020
    Posts
    26
    Ok gentlemen, I am stuck and need some additional guidance please. I have burned about 15 chips for VE table mods and am getting no where. Here is a summary, any suggestions are appreciated.

    -Got WBO2 working and verified calibration, thanks it works!
    -Warmed up engine with an open loop only bin file. When engine is warm it is a little rich but pretty smooth. Something happens after a short run time and I get flat lean spots around 1100 and 1800 rpm. I have been tuning all the VE tables to 14.1. These flat spots occur if i am slowly increasing the throttle from a low rpm or decreasing the throttle from about 2300.
    -My VE map has become maxed out, should I drop my injector flowrate?
    -Repeated this test hot but with closed loop, similar results.
    Bin attached and the two data logs if you could please take a look and make suggestions. My on idle and off idle maps seem very rough. Again I am only taking data sitting in park out to 2400 rpm or so.

    thank you.
    Attached Files Attached Files

  3. #33
    Super Moderator dave w's Avatar
    Join Date
    Feb 2011
    Posts
    4,466
    Summary from OPEN TO CLOSED LOOP WARM.xdl AFR's using WBO2 spreadsheet.

    dave w

    gearhead-efi.jpg

  4. #34
    Fuel Injected!
    Join Date
    Feb 2020
    Posts
    26
    Thanks Dave. I did find one thing, the AE vs tps values were too high resulting in a very rich condition when winging the throttle, I backed those off and things got better. It appears that even in open loop idle that if things get really lean the ECU kicks in AE to keep from stalling, true? Sounds like I need to keep working the fuel tables. TP5 only has only one WB02 history table, but for BLM's it has an on idle and off idle. For the WB02 table I have been picking of the values that will go into the off idle excel table, is this correct? Or is there a way to add an on idle and off idle WB02 table? I am also using history average WB02 from TP5.
    thanks,
    Mark

  5. #35
    Fuel Injected!
    Join Date
    Feb 2020
    Posts
    26
    Well, mostly dialed in up to 2400 rpm, holds well at 14.1. I closed the o2 loop and it is running pretty smooth, almost confident enough for a drive. I am trying to dial in the AE because it goes pretty rich when I hit the throttle.
    I have been playing with the AE vs. Map difference and AE vs. TPS. Are these the correct tables and how do I know when to adjust which one? If I do adjust these should it be a percentage offset across the board or a value (DC) offset?
    thanks,
    Mark.

  6. #36
    Fuel Injected!
    Join Date
    Feb 2020
    Posts
    26
    Dave,
    reading through the zip file you posted on the wb02 tuning. Unfortunately I have an antiquated excel. Could you please post your WB VE excel editor in a .XLS format?

    possibly this VE editor you made is a newer version? '7427 VE Correction WBO2.zip (1.05 MB, 86 views)
    Last edited by 383K1500; 3 Weeks Ago at 09:32 AM.

  7. #37
    Super Moderator dave w's Avatar
    Join Date
    Feb 2011
    Posts
    4,466
    OpenOffice is a freeware option for opening Excel spreadsheets. https://www.openoffice.org/product/

    dave w

  8. #38
    Fuel Injected!
    Join Date
    Feb 2020
    Posts
    26
    Thanks, got it converted, no luck in functionality. I suppose I am going to have to find a newer version of excel.

  9. #39
    Super Moderator dave w's Avatar
    Join Date
    Feb 2011
    Posts
    4,466
    OpenOffice works with the spreadsheet included in the WBO2 Tuning.zip folder available in post #19.

    dave w

  10. #40
    Fuel Injected!
    Join Date
    Feb 2020
    Posts
    26
    Dave,
    could you please take a look at this correction sheet? For some reason the AFR corrections are not being pulled in. Did I miss something or put the data in the wrong locations?

    thanks,
    Mark
    Attached Files Attached Files
    Last edited by 383K1500; 2 Weeks Ago at 09:21 PM.

  11. #41
    Super Moderator dave w's Avatar
    Join Date
    Feb 2011
    Posts
    4,466
    The spreadsheet filters Open Loop vs. Closed Loop. Only closed loop data is "crunched' by the spreadsheet. You can change the values in column AJ from open to closed and press the "F9" key on the keyboard to initiate another "crunch".

    dave w

  12. #42
    Fuel Injected!
    Join Date
    Feb 2020
    Posts
    26
    Thanks, well I think I am beginning to believe it is an excel "thing". I changed "open" to "closed" and I have auto re-calculate but pressed F9 anyway, nothing changed.

  13. #43
    Super Moderator dave w's Avatar
    Join Date
    Feb 2011
    Posts
    4,466
    Quote Originally Posted by 383K1500 View Post
    Thanks, well I think I am beginning to believe it is an excel "thing". I changed "open" to "closed" and I have auto re-calculate but pressed F9 anyway, nothing changed.
    I'm going to agree, it's likely an Excel version compatibility "thing" with the average if function.

    dave w
    Attached Images Attached Images

  14. #44
    Fuel Injected!
    Join Date
    Feb 2020
    Posts
    26
    Ok, here is an update. Hope you are doing well and avoiding the virus.
    -Got a new version of excel, the spreadsheet works awesome thanks for sharing and taking the time to put it together! I burned several chips in the garage, engine much smoother, I still am open loop but all around AFR~14.1 up to about 2400 rpm.
    Couple of questions.
    -VE tables are still maxing out around 1600 rpm. I am running the caprice cop car injectors, my cylinder volume reflects the actual (383) I have dropped my injector constant its at 55 lb/hr, I am running 15 psi. Something seems wrong. I am planning on pulling in the injectors this weekend and putting them on the flow bench to verify I don't have some other issue.
    -Slight throttle tip-in around 2.7% TPS (900-1000 rpm) it goes really lean and unstable. Idles well at 750 rpm with good AFR, IAC counts at hot idle are 10-15. Anything in TPS settings that could be doing this? I also have a lean patch around 1600 rpm, maybe due to the VE table, when I am slowly increasing the throttle or if I power through it and slowly decrease the throttle. This seems to be more prominent when the engine is about 205F, at 195 it seems ok.

    thanks,
    Mark.

  15. #45
    Fuel Injected!
    Join Date
    Feb 2020
    Posts
    26
    Dave et. al.,

    I got my injector and other issues ironed out. I have managed to take the truck for a drive a few times around the neighborhood and did some logging and Dave's "wash and repeat" cycle. Thanks for taking the time to put the document together. It seems like I am making headway but I have a few questions and would appreciate if someone could look at this latest log file and possibly my bin to see if there are any glaring items I may be overlooking or if I should just continue wash and repeat.

    -During the drive when I let off the throttle the engine goes lean and the idle ~1200 rpm swings violently. If you look at my fuel map i have a very low trough in it around this point, or a high point at a lower rpm value. I figure I could lower the 800 rpm VE but I am hesitant to do anything manually and right now and am just following what the excel spread sheet tells me to.
    -Engine seems to run on the warm side, have a 195 thermostat with 3 row aluminum radiator, could my timing be off? I do recall Dave or someone mentioning to start with the 98 vortec timing map, but I am hesitant to change too many things at once, thoughts please :)
    -Is there a general rule of when I should shift between using the "coarse tune" to the "fine tune" calculation results.
    -I would appreciate a look at the spreadsheet, don't see a lot of knock counts, seems like it is functioning, can you look?
    -My injector constant is still low ~60lb/hr, I am running the caprice 65lb/hr injectors at 17 psi. Does this seem unreasonable.

    Thanks in advance for any thoughts or suggestions and I appreciate your time. Hope you guys are staying healthy!

    Mark
    Attached Files Attached Files

Similar Threads

  1. Need a bit of help refreshing memory on 93LT-1 Chip
    By Performance SS in forum GM EFI Systems
    Replies: 6
    Last Post: 01-16-2019, 04:23 AM
  2. How to monitor RAM memory - OBD II
    By turbo_bu in forum OBDII Tuning
    Replies: 3
    Last Post: 04-28-2017, 02:41 PM
  3. GM memory seats
    By grasshopperglock in forum Gear Heads
    Replies: 0
    Last Post: 02-24-2015, 11:46 PM
  4. screwy bin or human error
    By b1500 in forum GM EFI Systems
    Replies: 3
    Last Post: 10-05-2014, 06:55 PM
  5. Looking for Guidance
    By jlsmith in forum Introductions
    Replies: 4
    Last Post: 05-07-2014, 09:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •