Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Page 2 of 4 FirstFirst 1234 LastLast
Results 16 to 30 of 46

Thread: GM TBI 383 $0D bad human memory need some guidance.

  1. #16
    Fuel Injected!
    Join Date
    Feb 2020
    Posts
    27
    I found some notes in TP5 that mentioned to hook the WB02 to pin B16 linear EGR pintle. I have no wire on B16 but have a grey EGR wire on pin E1. It also mentions to disable the EGR in the bin. Does this sound correct? Also do I need to physically disconnect the connector on the EGR vacuum valve?

  2. #17
    Super Moderator dave w's Avatar
    Join Date
    Feb 2011
    Posts
    4,533
    WBO2 Modified .bin attached.

    dave w
    Attached Files Attached Files

  3. #18
    Fuel Injected!
    Join Date
    Feb 2020
    Posts
    27
    Thanks Dave. So what was modified in this file, disabled egr or? I did find notes of what to disable in TP5, would like to understand if there is more.
    I have discovered that there were three types of EGR system on my truck, a two wire solenoid, a three wire solenoid and a five wire linear EGR control for a pintle. I have the two wire solenoid. All systems use wire E1 (grey) on the blue connnector, the 5.7L red connector shows B16 as unused which is my case but the 7L shows B16 as an EGR pintle control.
    Sooooo, should I be feeding the 0-5V signal into B16 though I do not have a linear EGR? I am really skiddish about plumbing in voltages and signals into the system without being absolutely sure, I don't want to fry anything. :)

  4. #19
    Super Moderator dave w's Avatar
    Join Date
    Feb 2011
    Posts
    4,533
    Edit Log for WBO2_old383MODIFIED2.BIN created by TunerPro.
    ************************************************** ************************
    03/08/2020 09:22:34 Flag: Linear EGR/EVRV EGR changed from Not Set to Set..
    03/08/2020 09:22:56 Flag: Code 32 EGR Failure changed from Set to Not Set..
    03/08/2020 09:24:17 Flag: Backpressure EGR changed from Set to Not Set..
    03/08/2020 09:29:09 Table: Desired EGR vs. RPM vs. Vacuum changed.
    03/08/2020 09:30:40 Table: EGR Fuel Reduction vs. RPM vs. Vacuum changed.

    The information posted above has the detailed information from TP5 for the changes from old383MODIFIED2.BIN to WBO2_old383MODIFIED2.BIN. The changes above DISABLED ALL THREE EGR TYPES.

    The attached .zip has detailed WBO2 information, including a WBO2 tuning spreadsheet and pictures.

    dave w
    Attached Files Attached Files

  5. #20
    Fuel Injected!
    Join Date
    Feb 2020
    Posts
    27
    Thank you Dave!
    I will read through this info.

  6. #21
    Super Moderator dave w's Avatar
    Join Date
    Feb 2011
    Posts
    4,533
    Edit Log for WBO2_old383MODIFIED3.BIN created by TunerPro.
    ************************************************** ************************
    03/08/2020 10:51:37 Scalar: Temperature for EGR On changed from 74.8 C (0x99) to 151.3 C (0xFF).
    03/08/2020 10:52:12 Scalar: Temperature for EGR Off changed from 44.8 C (0x71) to 149.0 C (0xFC).
    03/08/2020 10:52:26 Scalar: Minimum Speed for EGR changed from 0.0 MPH (0x00) to 255.0 MPH (0xFF).
    03/08/2020 10:52:34 Scalar: RPM for EGR On changed from 850 RPM (0x22) to 6375 RPM (0xFF).
    03/08/2020 10:52:47 Scalar: RPM for EGR Off changed from 800 RPM (0x20) to 6275 RPM (0xFB).


    Quote Originally Posted by dave w View Post
    The changes above DISABLED ALL THREE EGR TYPES.dave w
    On second thought, the updates to WBO2_old383MODIFIED3.BIN WILL disable all three types of EGR's. Ok there is a slight possibility the EGR could still come on, but the speed sensor will have to exceed 255 MPH + engine temperature sensor will have to exceed 151.3 Celsius (304 Fahrenheit) + engine RPM signal exceeding 6375 RPM. Seemingly it would be impossible to have the EGR turn on with the above parameter programming, If however the EGR should come on, the EGR will turn off once any of the following three occurs: the speed is below 252 MPH, engine temperature is below 149 Celsius, and engine below 6275. I suppose with the above EGR programming and removing and blocking off the EGR will IN FACT prevent the EGR from ever coming on, thus preventing any EGR performance concerns in the tuning process. Placing a tombstone on the EGR block-off plate is optional.

    dave w
    Attached Files Attached Files

  7. #22
    Fuel Injected!
    Join Date
    Feb 2020
    Posts
    27
    LOL, ok thank you! Well it just my 94 work truck, I don't think I will be going over 255 but it would be nice if I could! The info you previously sent is very helpful, thank you. I need to try and find an ECU pin for B16 so that is my task today.
    Also is the second bin you sent any different from the first, i.e. should I be using the second one?
    Thanks again for the help, I hope to get this going today.

  8. #23
    Super Moderator dave w's Avatar
    Join Date
    Feb 2011
    Posts
    4,533
    Yes, use the 2nd .bin file I posted.

  9. #24
    Fuel Injected!
    Join Date
    Feb 2020
    Posts
    27
    Ok, thanks.
    One other question that I could not find the info for in the zip you sent. Does the ECU expect a +0 to 5Vdc input on pin B16 or can it be a +0 to -5Vdc? My WB voltage is negative. Do I need to figure out how to make this a positive voltage or can i fix it in the BIN?

  10. #25
    Super Moderator dave w's Avatar
    Join Date
    Feb 2011
    Posts
    4,533
    Hmmm, I'm not sure what to say about the negative -5volt signal from the WBO2.

    The '7427 WBO2 "hack / patch" works with a 0 volt to 5 volt WBO2 by re-purposing the Linear EGR position 0 to 5v circuit.

    dave w

  11. #26
    Fuel Injected! Terminal_Crazy's Avatar
    Join Date
    Oct 2015
    Location
    Lancashire England
    Posts
    354
    Quote Originally Posted by 383K1500 View Post
    Ok, thanks.
    One other question that I could not find the info for in the zip you sent. Does the ECU expect a +0 to 5Vdc input on pin B16 or can it be a +0 to -5Vdc? My WB voltage is negative. Do I need to figure out how to make this a positive voltage or can i fix it in the BIN?
    Try swapping your Test Leads over and test again!

    Mitch
    '95 Z28 M6 -Just the odd mod.
    '80 350 A3 C3 Corvette - recent addition.

  12. #27
    Fuel Injected!
    Join Date
    Nov 2017
    Age
    53
    Posts
    260
    Quote Originally Posted by 383K1500 View Post
    Ok, thanks.
    One other question that I could not find the info for in the zip you sent. Does the ECU expect a +0 to 5Vdc input on pin B16 or can it be a +0 to -5Vdc? My WB voltage is negative. Do I need to figure out how to make this a positive voltage or can i fix it in the BIN?
    Are you sure about that? I've never seen anyone make a 0 to -5v output. You can see that on your voltmeter if you have the probes hooked up backwards.
    -Carl

  13. #28
    Fuel Injected!
    Join Date
    Nov 2017
    Age
    53
    Posts
    260
    Quote Originally Posted by Terminal_Crazy View Post
    Try swapping your Test Leads over and test again!

    Mitch
    Treed, DOH!
    -Carl

  14. #29
    Fuel Injected!
    Join Date
    Feb 2020
    Posts
    27
    Ok gents, I have that issue ironed out. I hate to admit it but yes, I got the red and black wire swapped on my DVM

    So I did get the connector pins and have everything hooked up. When I fire up TPV5 and look in the history tables all the blocks where the engine is running fill in with the number "10". What am I missing, yes the WBO2 is plugged in and attached to B16. :)

  15. #30
    Super Moderator dave w's Avatar
    Join Date
    Feb 2011
    Posts
    4,533
    Try using the .bin file in post #21.

    dave w

Similar Threads

  1. Need a bit of help refreshing memory on 93LT-1 Chip
    By Performance SS in forum GM EFI Systems
    Replies: 6
    Last Post: 01-16-2019, 04:23 AM
  2. How to monitor RAM memory - OBD II
    By turbo_bu in forum OBDII Tuning
    Replies: 3
    Last Post: 04-28-2017, 02:41 PM
  3. GM memory seats
    By grasshopperglock in forum Gear Heads
    Replies: 0
    Last Post: 02-24-2015, 11:46 PM
  4. screwy bin or human error
    By b1500 in forum GM EFI Systems
    Replies: 3
    Last Post: 10-05-2014, 06:55 PM
  5. Looking for Guidance
    By jlsmith in forum Introductions
    Replies: 4
    Last Post: 05-07-2014, 09:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •