Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Page 3 of 4 FirstFirst 1234 LastLast
Results 31 to 45 of 48

Thread: OBD logging and real-time histogram

  1. #31
    Fuel Injected! woody80z28's Avatar
    Join Date
    Nov 2011
    Location
    Walton, NY
    Age
    34
    Posts
    235
    Quote Originally Posted by kur4o View Post
    I will try to get the patch done ASAP. I didn`t have much free time recently.

    Stay tuned.
    Hold off on that for a bit if you haven't already started. I've got another BIN manually modified by another member to get PE working. I gotta test that out today. Thanks!
    80 Camaro Z28 - 550hp AFR 383 / T56 6spd (Holley HP EFI)
    91 Beretta "SS" - 260hp 3400 MPFI / HM282 5spd (7730/$A1)
    94 Silverado Z71 - 300hp Vortec 357 TBI / NV4500 5spd (7427/$0D) gone but not forgotten
    01 Silverado 2500HD - stock Vortec 8.1 / ZF6 6spd (0411/8322)

  2. #32
    Fuel Injected!
    Join Date
    Mar 2013
    Posts
    939
    $12 -1byte -Air fuel target
    $13 -1byte -11a6 knock retard
    $16 -2byte -114b egr feedback[I will rip the 16bit data straight from the AD readings] stock have some filtering.
    $1c -1byte -1144 AC pressure switch[in case you want to log wideband through AC, or add second wideband]
    $1e -2byte - gm/cyl value used for table lookup.


    I set the patch as this. 16bit value of egr is straight from the AD channel. You need to log some voltages to figure the conversion factor.

    You can use the small program I attached to apply the patch. UNzip to a folder and run from there [.net 4 is needed to run it], click on modify and select the bin you want to patch, click add patches, select the patch and than save the modified bin. You have to write OS for the flash to take effect.
    Attached Files Attached Files

  3. #33
    Fuel Injected! woody80z28's Avatar
    Join Date
    Nov 2011
    Location
    Walton, NY
    Age
    34
    Posts
    235
    That is slick as shit! Works nice, thank you. I'm gonna flash that BIN hopefully tmo. The PE is working as of tonight, so I'm finally getting somewhere with this thing.

    Gearhead rules!
    80 Camaro Z28 - 550hp AFR 383 / T56 6spd (Holley HP EFI)
    91 Beretta "SS" - 260hp 3400 MPFI / HM282 5spd (7730/$A1)
    94 Silverado Z71 - 300hp Vortec 357 TBI / NV4500 5spd (7427/$0D) gone but not forgotten
    01 Silverado 2500HD - stock Vortec 8.1 / ZF6 6spd (0411/8322)

  4. #34
    Fuel Injected! woody80z28's Avatar
    Join Date
    Nov 2011
    Location
    Walton, NY
    Age
    34
    Posts
    235
    So I got the BIN flashed and I'm getting my ADX set up to try this out. Setting them up is fairly straightforward...until it comes time to figure out the formulas for $119E Air Fuel Ratio and $11A6 Knock Retard. I found the formula for PID68 Target EQ [2/65536 * X], but I'm not confident that's right. I found nothing applicable for a knock retard formula at all. I could try to use the regular spark advance formula I suppose...
    80 Camaro Z28 - 550hp AFR 383 / T56 6spd (Holley HP EFI)
    91 Beretta "SS" - 260hp 3400 MPFI / HM282 5spd (7730/$A1)
    94 Silverado Z71 - 300hp Vortec 357 TBI / NV4500 5spd (7427/$0D) gone but not forgotten
    01 Silverado 2500HD - stock Vortec 8.1 / ZF6 6spd (0411/8322)

  5. #35
    Fuel Injected!
    Join Date
    Mar 2013
    Posts
    939
    For afr try x/10 conversion. If you got close to 14.7 at closed loop it is correct.
    knock retard could be something like x/11.378

  6. #36
    Fuel Injected! woody80z28's Avatar
    Join Date
    Nov 2011
    Location
    Walton, NY
    Age
    34
    Posts
    235
    So, after trying a few things...I'm pretty much at a loss.

    These PIDs I've tried to add don't work. The custom patched ones such as Target AFR and Knock Retard, but also the standard B1S2 o2 voltage for WBo2 (however, this truck doesn't have a post-cat sensor from the factory). As I'm typing this, it makes me wonder now if I can add another standard PID that this truck should have like B1S1 o2 voltage.

    What I've confirmed is that these PIDs I've tried to add conform to the PID directly above it in the monitor macro for commands (capture attached). So it seems to ignore the PID I added and use the value received from the previous RX. So I can't even test the formulas to see if they are right.

    I'll post a log later with an ADX to show what I mean.

    Ugh.
    Attached Images Attached Images
    80 Camaro Z28 - 550hp AFR 383 / T56 6spd (Holley HP EFI)
    91 Beretta "SS" - 260hp 3400 MPFI / HM282 5spd (7730/$A1)
    94 Silverado Z71 - 300hp Vortec 357 TBI / NV4500 5spd (7427/$0D) gone but not forgotten
    01 Silverado 2500HD - stock Vortec 8.1 / ZF6 6spd (0411/8322)

  7. #37
    Fuel Injected!
    Join Date
    Mar 2013
    Posts
    939
    Post the current adx, maybe there is some config issue.

  8. #38
    Fuel Injected! woody80z28's Avatar
    Join Date
    Nov 2011
    Location
    Walton, NY
    Age
    34
    Posts
    235
    Ok, log329.xdl and patch.adx go together; both files with reduced go together also. Originally I had the added PIDs at the bottom of the commands list and wondered if it would only receixe X amount of data. So I made another one that reduced the overall PIDs and dispersed them in between the standard ones so they weren't at the bottom of the list. That's how I discovered that the added PIDs get filled in with the data from the standard PIDs immediately before them.

    Hopefully you can discover something I did wrong! haha

    BTW: that b1s1 adx had the wideband charged to just read bank 1 sensor 1 narrowband o2 voltage. It appeared to be correct while driving.
    Attached Files Attached Files
    Last edited by woody80z28; 03-30-2020 at 01:43 AM.
    80 Camaro Z28 - 550hp AFR 383 / T56 6spd (Holley HP EFI)
    91 Beretta "SS" - 260hp 3400 MPFI / HM282 5spd (7730/$A1)
    94 Silverado Z71 - 300hp Vortec 357 TBI / NV4500 5spd (7427/$0D) gone but not forgotten
    01 Silverado 2500HD - stock Vortec 8.1 / ZF6 6spd (0411/8322)

  9. #39
    Fuel Injected!
    Join Date
    Mar 2013
    Posts
    939
    Have no clue where is the problem in tunerpro, in patch or in both or vehicle doesn`t support AFR the way we know it. At least for sure there is some data sent on the target afr, so patch kind a works.

    I think only manual troubleshooting can find the problem.

    Sending some custom commands with stnterm.exe can give more clues what is not working.
    If you are willing to try I will get you some commands.

  10. #40
    Fuel Injected! woody80z28's Avatar
    Join Date
    Nov 2011
    Location
    Walton, NY
    Age
    34
    Posts
    235
    That kind of thing is above my current level of understanding, but I'm willing to learn it.
    80 Camaro Z28 - 550hp AFR 383 / T56 6spd (Holley HP EFI)
    91 Beretta "SS" - 260hp 3400 MPFI / HM282 5spd (7730/$A1)
    94 Silverado Z71 - 300hp Vortec 357 TBI / NV4500 5spd (7427/$0D) gone but not forgotten
    01 Silverado 2500HD - stock Vortec 8.1 / ZF6 6spd (0411/8322)

  11. #41
    Fuel Injected!
    Join Date
    Mar 2013
    Posts
    939
    Here is the stnterm.

    Upon starting select the comm port and baud rate of the elm device. If you are unsure of the comm port open device manager and see the number there.

    Pressing the ATI button will get you the elm id.
    When you are sure you have good communication with the elm device, send ATSP 2 . This will set the protocol to j1850 vpw.

    Now you can send custom request to pcm. Like requesting different pids.

    To request mode1 sae pids type

    01xx

    01=mode
    xx= sae pid number 01-ff

    To request mode 01 pid 1c simply send
    011c and you will get the result.
    If you get a 7f reply, this means that the pid is not supported or the request is in invalid format.


    To request enhanced pids you will use mode 22 requests.
    the format is

    22xxxx01

    22=mode
    xxxx=pid
    01=??byte count request?? not sure on this but in most cases 01 will do the job.

    So 119e pid can be requested by sending

    22119e01

    Let me know how you are coping with this so we can get to level2.
    Attached Files Attached Files

  12. #42
    Fuel Injected!
    Join Date
    Mar 2013
    Posts
    939
    To get mode22 working you might need to change the header first.

    send

    ATSH6C10F0

    After that mode 22 requests should work fine.

  13. #43
    Fuel Injected! woody80z28's Avatar
    Join Date
    Nov 2011
    Location
    Walton, NY
    Age
    34
    Posts
    235
    Ok, I got the COM and baud figured out COM5 and 9600. I know ELM is communicating because I connected in TunerPro and then closed out. I even unplugged and replugged after closing TP to make sure it wasn't "busy" before opening stterm.

    Key on, engine running: I send "ATSP 2" and it shows in the list red with no response. Same thing with PIDs I tried: 0112, 0107, 010D. What am I doing wrong?
    80 Camaro Z28 - 550hp AFR 383 / T56 6spd (Holley HP EFI)
    91 Beretta "SS" - 260hp 3400 MPFI / HM282 5spd (7730/$A1)
    94 Silverado Z71 - 300hp Vortec 357 TBI / NV4500 5spd (7427/$0D) gone but not forgotten
    01 Silverado 2500HD - stock Vortec 8.1 / ZF6 6spd (0411/8322)

  14. #44
    Fuel Injected!
    Join Date
    Mar 2013
    Posts
    939
    Pressing any of the built in button does it return a reply. I am sure it is set for different baud rate stock, so try all of them until you get a communication from the tool.
    You can try sending it without the space: atsp2. Before opening make sure the bluetooth is paired and the com port is not used by other software.

    Ignore tunerpro settings since it can request different baud rate. 9600 is extremely slow, try upping it to 115000 in tunerpro and see if it connects.

  15. #45
    Fuel Injected!
    Join Date
    Mar 2013
    Posts
    939
    Found that some of the later version of tunerpro supports 2 bytes pid requests. I will give it a try and hopefully it will work.

Similar Threads

  1. TP-V5 W/Ostrich 93 Vette real time connecting problem.
    By Axman in forum TunerPro Tuning Talk
    Replies: 0
    Last Post: 07-16-2016, 04:57 AM
  2. how to start real time tuning?
    By Scrufdog in forum TunerPro Tuning Talk
    Replies: 14
    Last Post: 10-03-2014, 12:24 AM
  3. $42 VSS Filtering in REAL TIME SERVICE ROUTINE B
    By jim_in_dorris in forum GM EFI Systems
    Replies: 0
    Last Post: 08-16-2014, 09:12 AM
  4. Histogram viewing of xls files?
    By 1project2many in forum TunerPro Tuning Talk
    Replies: 4
    Last Post: 02-05-2012, 05:49 AM
  5. '427 Tuning ~ Excel vs TunerPro RT Histogram
    By dave w in forum GM EFI Systems
    Replies: 0
    Last Post: 10-29-2011, 04:24 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •