Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Results 1 to 15 of 19

Thread: 4L80 acting weird AFTER adding wire for TCC

Hybrid View

  1. #1
    Fuel Injected! CDeeZ's Avatar
    Join Date
    May 2012
    Location
    Jokelahoma
    Posts
    422

    4L80 acting weird AFTER adding wire for TCC

    I have been driving my 4L80 around without the TCC wired up. Last night, I wired in the TCC.

    I swapped in the 7427 PCM in this truck a few years back and everything was ok then.
    I also wired it just as is described in the conversion thread here: http://www.gearhead-efi.com/Fuel-Inj...php?t-173.html

    The truck USED to have a 700R4 so when I swapped in the 7427 a few years back I put the Orange wire from the brake switch to pin E13 at the PCM: E13--------Orange-----------Battery (Inputed in place of Brake Switchfor TCC to function)

    Now last night I started tracing the Purple wire from the brake switch and found that it in fact does go to a diode module under the dash for the ABS system. I deleted the ABS system on this truck... So what I did was i cut the one purple wire going FROM the brake switch TO the ABS diode module and I pinned that purple wire into pin E13 in place of the orange wire that WAS there.


    This trans has worked flawlessly so far, albeit running without the TCC functioning. There is a big cooler setup on it that I borrowed from a SuperDuty F250 or F350 so I don't think it was ever getting very warm.

    Took it out for a test today and it felt weird like either the converter was locking and unlocking -AND/OR- the trans was hunting between 3rd and 4th gear.... BEFORE I captured the log I'm posting, I was driving and when the TCC locked in what I think was 3rd gear, I could tap the brake switch and make it unlock/lock like you would expect. However, I soon realized an issue, which I DID capture with the attached log.

    If you start this log at 44 seconds in you can then shortly thereafter see it hunt between 3rd and 4th and it even loses the data stream connection at least once around this time also.......

    In this trans ADX the TPS shows 22%, but if I switch back to the regular ADX, the non transmission one it shows what the TPS ACTUALLY IS, which is nowhere near 22%, more like 0% or 1.2% max (my throttle is a bit sticky lol) COULD this ADX be screwed and the erroneous TPS reading be causing this issue????

    I have been scanning the trans using the
    A220 Trans1 $0E TP5 v250.adx.... The 2nd one doesn't seem to offer much or do anything?

    I found this thread where Billy is talking about no using the brake switch for the TCC (post #3):
    http://www.gearhead-efi.com/Fuel-Injection/showthread.php?4128-TH400-to-4L80E-swap-and-1227747-to-16197427-swap

    ANd this one where Dave is talking about a relay???? I thought the relay was only for if you are swapping from 4L60e to 4L80e??? (post #16)
    https://ck5.com/forums/threads/compu...o-help.295902/
    Attached Files Attached Files
    Last edited by CDeeZ; 02-10-2019 at 12:38 PM.

  2. #2
    Fuel Injected! CDeeZ's Avatar
    Join Date
    May 2012
    Location
    Jokelahoma
    Posts
    422
    Here is how I wired the TCC as per the 6395 PCM...
    Attached Images Attached Images

  3. #3
    Fuel Injected! CDeeZ's Avatar
    Join Date
    May 2012
    Location
    Jokelahoma
    Posts
    422
    No one? I readjusted the brake switch and confirmed that it has power ON brake OFF and power OFF brake ON at the respective TCC pin E13... The TCC seemed to unlock correctly at lower speeds as I said, but once I kept going it started acting real werid when it was locking up in 4th.

    Guess if I can't get this working like GM intended it I will either not run a TCC at all, or, wire the TCC into a toggle and control in manually.

  4. #4
    Fuel Injected! sturgillbd's Avatar
    Join Date
    Jun 2012
    Location
    Big Stone Gap, VA
    Age
    45
    Posts
    472
    Are you using E11 for your TCC? There are two different TCC outputs on this PCM and it all depends on which Mask and transmission you use.

  5. #5
    Fuel Injected!
    Join Date
    Aug 2012
    Posts
    364
    Have you modded any of the lock unlock speeds. Years ago I was fooling with numbers and had that lock unlock problem. Turned out for me if you violate the spread/hysteriasis that can be a problem. Once I corrected things have been fine for years.
    6395, BHDF, 7.4 BBC lightly modded now 6395 BMHM back to BHDF

  6. #6
    Fuel Injected! CDeeZ's Avatar
    Join Date
    May 2012
    Location
    Jokelahoma
    Posts
    422
    I have the brake signal pinned into E13 just like in that diagram above. I have not modified any of the TCC paramteres in the BJDR bin.

    I have been driving it with and without the brake signal pinned in to that spot. The NEW issues is present either way so it must be unrelated. It locks and unlocks correctly when I tap the brake pedal with the wire pinned in. Whatever this newest issue is I'm guessing is unrelated to the TCC since the issue is there with or without the TCC brake signal wire there... I pulled the fuel pump out and the fitler/sock was filthy so I replaced it but no difference. Making 27 or so PSI idle, but I can't see the gauge driving so I don't know if that's an issue.

    I'm wondering if the plugs are fouled again causing this new issue. I can see most all of the sensors spike down to 0 in a datalog when this issue happens. Battery voltage stays the same.

Similar Threads

  1. 4l80 pmc tune
    By honsolow in forum OBDII Tuning
    Replies: 2
    Last Post: 09-30-2018, 07:04 AM
  2. $31 / $0E 4L80 tables
    By V8Astro in forum GM EFI Systems
    Replies: 2
    Last Post: 11-24-2015, 11:27 AM
  3. Replies: 5
    Last Post: 01-09-2014, 09:05 PM
  4. TBI acting like a carb with maladjusted float.
    By 1BadAction in forum GM EFI Systems
    Replies: 8
    Last Post: 06-18-2013, 06:32 AM
  5. Red wire and white wire on ALDL???
    By Blazer3664 in forum GM EFI Systems
    Replies: 2
    Last Post: 01-06-2013, 03:53 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •