Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Results 1 to 3 of 3

Thread: LT1 tuning

  1. #1
    Fuel Injected! Terminal_Crazy's Avatar
    Join Date
    Oct 2015
    Location
    Lancashire England
    Posts
    235

    LT1 tuning

    Ok. Iíve been tuning this LT1 for a while now.
    Recently replaced the injectors and retuned OLSD.
    The car is running pretty decent. VE map Ok but not perfect.
    PEís in the 12.8 area mainly.

    I just swapped back to CL (with the stock O2 parameters) and obviously the idle is noticeably crap,
    I havenít yet played with Kur4oís live O2 mods so thatís next on the agenda.
    Whilst I can play around with the idle, how would these changes affect the other BLMís across the table?

    What I did notice is that the BLMís Have dropped to around varyingly to 115 (lowest). Biggest split is 4 points, most are about 1 or 2 so pleased with that.
    However, the wideband logs in EEHack are all showing lean up to 16/17:1 in places.
    PE mode still shows reasonable wot values.

    Not sure what to trust or which direction to go in.
    If I lower VEís to get BLMís back in-line then the wideband is showing as lean.

    Thanks
    Mitch
    '95 Z28 M6 -Just the odd mod.
    '80 350 A3 C3 Corvette - recent addition.

  2. #2
    Fuel Injected!
    Join Date
    Mar 2013
    Posts
    465
    PCM reads false rich condition and substracts fuel. That`s why you got lean condition at idle.
    You can try to play with 02 controls. Most of the 02 tables use only the first cell at idle.
    If that not help, make it pig reach at idle so when the pcm starts removing fuel at CL you get a reasonable afr mixture.
    As a last resort run open loop at idle.

    The best strategy is to tune idle VE in open loop and than start playing with 02 settings.

  3. #3
    Fuel Injected! Terminal_Crazy's Avatar
    Join Date
    Oct 2015
    Location
    Lancashire England
    Posts
    235
    Hi
    Quote Originally Posted by kur4o View Post
    PCM reads false rich condition and substracts fuel. That`s why you got lean condition at idle.
    I'm getting all across the whole BLM/VE Tables.

    You can try to play with 02 controls. Most of the 02 tables use only the first cell at idle.
    That's next on my agends with your software controls.

    [QUOTE}
    If that not help, make it pig reach at idle so when the pcm starts removing fuel at CL you get a reasonable afr mixture.
    As a last resort run open loop at idle.

    The best strategy is to tune idle VE in open loop and than start playing with 02 settings.[/QUOTE]

    But that would only improve the idle won't it, not the rest of the fueling that's now showing lean?

    OL certainly seems to run smoother.
    I'm more after wanting Closed Loop Idle for the "Emmissions" and then can go OL once she's rolling.

    My other option could be to keep it Open Loop and reconect/switch back on the MAF for when I want a CL.
    I could just plug the MAF back in when required.
    Would this work ?


    Thanks
    Mitch
    '95 Z28 M6 -Just the odd mod.
    '80 350 A3 C3 Corvette - recent addition.

Similar Threads

  1. Tuning 85 TPI - Need spark tuning advice
    By BlueCorvette in forum GM EFI Systems
    Replies: 11
    Last Post: 01-25-2017, 07:54 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •