Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Results 1 to 5 of 5

Thread: Tuning help needed - '91 TBI 383 w/ Vortec heads

  1. #1
    Carb and Points!
    Join Date
    Apr 2017
    Posts
    5

    Tuning help needed - '91 TBI 383 w/ Vortec heads

    Hi all, could use some tuning advice.

    I've built and installed a vortec-head 383 in my '91 squarebody suburban. 3/4 ton, 4wd, 4L80e tranny. 16147060 PCM, using $85 mask. Here's my intro thread for some more info:

    http://www.gearhead-efi.com/Fuel-Inj...ortec-head-383

    Considering my complete lack of experience with tuning, it's running decent. I know it's running rich and I'm continuing to play with the BLM table using my log files and an adjustment spreadsheet that @Dave W provided me. But other than that, I'm unsure of where to go next with tuning, e.g. spark, IAC, choke, etc. My two biggest concerns (other than still a bit rich) are,

    1. Significant surging during compression braking. I can hear it out the tailpipe, see it in the tach (300-400 rpm surge range, cycle time is about 1 second) and feel it in the seat of the pants. It might be doing the same thing, but very slightly, during steady, low speed cruise, too. But going down hills with foot off throttle and brakes, it's pretty bad.

    2. High idle at cold startup. 1200-1300 rpm, doesn't match target idle in .BIN. Takes several minutes before it will even come down to below 1000.

    Do these issues sound like they're related? Vacuum leak? I've attached all the files I'm using in TunerPro, including my two latest log files and my latest modified .bin file - just in case anyone has the desire to take a look.

    Oh, and EGR has been deleted via RPM limits (Dave W helped with that on initial .BIN creation) and no EGR valve physically installed. EGR is complicated on Vortecs - need to route exhaust gas from DS exhaust manifold to intake manifold.

    Thanks much!
    Attached Files Attached Files

  2. #2
    Fuel Injected!
    Join Date
    Apr 2017
    Location
    Oregon
    Posts
    89
    It looks like three weeks and no one responded. Do you have a wide band o2 hooked up? If so what's it reading during your decel problem? You could have a vacuum leak, the only way to tell is to check. A smoke machine is what I prefer. There are instructions online on how to make one for not much money. There are other ways, but sometimes they miss leaks.

  3. #3
    Carb and Points!
    Join Date
    Apr 2017
    Posts
    5
    Quote Originally Posted by donf View Post
    It looks like three weeks and no one responded. Do you have a wide band o2 hooked up? If so what's it reading during your decel problem? You could have a vacuum leak, the only way to tell is to check. A smoke machine is what I prefer. There are instructions online on how to make one for not much money. There are other ways, but sometimes they miss leaks.
    Thanks for the response. I haven't been able to do anything for a couple weeks due to a severely leaking tranny, but that is resolved now so back to the tuning. I'm leaning away from vacuum leak since it's now running pretty good with the only exception being surging at deceleration. Decelerates smoothly down to about 1500 rpm and then between there and about 1100 rpm there's a crazy oscillation between the two, back and forth on the tach and audible. Then once it's down below 1100 and all the way to 650 idle - smooth as butter. I found another thread on here that may hold some insights. Going to start working through some of those issues. I'm still running pretty rich, too. I also recently did the adjustable FPR conversion (using the stock regulator and making the spring cup adjustable) -- I only had about 8 psi before that, now I'm back up to 12-13.

    No WB O2 sensor. I may go that way, but would prefer to stay stock if I can get it to work. I did get a new Y-pipe made recently and I had him put in additional bungs but not sure they'll work for wide band. Stock O2 is just after the two legs of the Y come together, but he added bungs upstream of that, one in each leg of the Y. Would that work?

  4. #4
    Fuel Injected!
    Join Date
    Apr 2017
    Location
    Oregon
    Posts
    89
    Great progress! The other thread you found has some great info. The reason the factory had the unheated o2 in the exhaust manifold was heat, when they relocated it to the y pipe in later years they installed a heated three wire o2 from the factory. The wide band is also heated and can be mounted pretty much anywhere in the exhaust. I wouldn't waste my time without a wideband. It can be done but really the tune should be more accurate with the wideband and dataloging. I see it all the time, people spend thousands upgrading then compromise the results with a shifty tune. A wide band is cheap and can be sold or rented to friends once your done with it.

  5. #5
    Carb and Points!
    Join Date
    Apr 2017
    Posts
    5
    Thanks, I'm definitely considering the wideband. Going to start though with just converting existing O2 to three wire. I agree with the reasons you state about why they changed to 3-wire, but I don't think they had made that change yet in '91. As best I can tell, it came stock in the current location (after the Y pipe junction, before the cat) and was never heated. But it seems like a good start to just swap out that one wire unit for a 3 wire. Then, if I want to add WB, I can add it into one of the banks, before the y-junction, since I have a bung in each bank now.

Similar Threads

  1. Squarebody with TBI and Vortec Heads
    By brandon6469 in forum Introductions
    Replies: 0
    Last Post: 09-29-2016, 09:07 PM
  2. Modified Vortec heads
    By old truck guy in forum Buy - Sell - Trade - Wanted
    Replies: 0
    Last Post: 02-15-2016, 09:17 AM
  3. 4.3 tbi with vortec heads need chip help
    By ls1 in forum GM EFI Systems
    Replies: 9
    Last Post: 12-23-2015, 10:09 AM
  4. WTB 062/906 vortec heads
    By Tylerz281500 in forum Buy - Sell - Trade - Wanted
    Replies: 0
    Last Post: 01-04-2015, 01:05 PM
  5. tbi into 76 vortec heads ?
    By BIGWORM76 in forum GM EFI Systems
    Replies: 33
    Last Post: 04-18-2013, 09:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •