Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 32

Thread: 1994 F body pcm for 1996 Y body obd II to obd I conversion?

  1. #16
    Fuel Injected! steveo's Avatar
    Join Date
    Aug 2013
    Posts
    2,424
    if your serial connection to the ECM is stable, eehack's tool should work fine, people have done lots of flash writes with it without issues.. but cats winflash is definitely more well tested, and commercially supported. if my free flash tool bricks your ECM you're on your own. no tool will save you from an unreliable serial connection.

  2. #17
    Fuel Injected!
    Join Date
    Oct 2013
    Posts
    893
    I'm pretty sure if CATS software bricks it you're on your own too. Use EEhack and just make sure the battery voltage is good and the comms are stable.

  3. #18
    Fuel Injected! steveo's Avatar
    Join Date
    Aug 2013
    Posts
    2,424
    I'm pretty sure if CATS software bricks it you're on your own too.
    he does offer a repair service, last i checked (i think he built himself an in-place bench reflashing thinger)

  4. #19
    Fuel Injected! steveo's Avatar
    Join Date
    Aug 2013
    Posts
    2,424
    its also worth mentioning that one advantage to eehack's flash write is that it's designed to write less packets. it remembers your last bin write and only flashes the half of the ECM you've changed, and it doesn't write anything to areas of the bin that the ECM doesn't actually look at.

    technically this should make it safer, but i think tunercat's tool is still more mature. he probably understand's EE's code better, and does this for a living, while i'm just a nerd who wanted to prove that i could write a flash tool that works.

  5. #20
    Electronic Ignition!
    Join Date
    Sep 2018
    Age
    28
    Posts
    18
    Iíve been wanting to use eehack since last year but I had to sell that project. I believe that it is the way to go and a lot of folks seem to think so as well. I hear there are things you can do to help make it safer. Like unplugging the fans and such that cycle during the flash. Iím going to run a charger on the car and use my mini desktop for the tuning that will be plugged into the wall.

  6. #21
    Electronic Ignition!
    Join Date
    Sep 2018
    Age
    28
    Posts
    18
    Well the day kinda ended in disappointment my red river cable will only work with 94/95 scan program as of now. Winflash or eehack just won’t communicate with the 94 pcm. I tried everything tried different windows compatibility whe whole deal. Reinstalled drivers and all kinds of stuff. Short of making a bench set up idk what else to try.

  7. #22
    Electronic Ignition!
    Join Date
    Sep 2018
    Age
    28
    Posts
    18
    Success! Started pulling fuses and the airbag/ccm ones did it. Specifically the ccm 3 is the one that does it. Well anyways she worked! Eehack kicks ass. I noticed I have a code 43 so I guess my solder mod for the knock sensor didn’t work, I’m goin to take it out of the ecu and try it in line. I’m getting a code 96 as well from the trans so I know I’m going to need to do the valve body but I’m very happy right now! Everything will come together soon.

  8. #23
    Fuel Injected!
    Join Date
    Mar 2013
    Posts
    445
    You need to load a calibration from 1995 on the PCM for the transmission.
    You sure you get code 96. Cant you just grab a knock sensor from 94-95 application and scrap that resistor mod.
    Make sure on the settings window in eehack to select y-body connection.

  9. #24
    Electronic Ignition!
    Join Date
    Sep 2018
    Age
    28
    Posts
    18
    Sorry that’s my bad it’s a code 97 for vss I jumped the gun. Yes I’m going to have to agree with you on the swapping the right knock sensor and ditching the resistor it’s just a more solid solution. I’ll pick one up tomorrow and see when I can use my buddy’s lift to swap it. All and all it seems to be working fine though. The bin I modified is a 95 bin so all the trans stuff is from there. Yes y body was set and it was silencing Aar and such but there was still to much chatter. Fuses pulled and it works fine I’ll live with it.

  10. #25
    Fuel Injected!
    Join Date
    Mar 2013
    Posts
    445
    Well it could be that the ccm use different address or gm somehow switched something on the aldl line communication.
    On the eehack`s main window there is a tab called raw. You can do an idle traffic scan log from there. I hope it will clear what is happening on the bus.

    The 95 calibration you have should be vette specific, since there is some differences on the communication side and on the vss side, different tooth counts if I remember right.
    I doubt they switched the vss sensor or the signal.

  11. #26
    Electronic Ignition!
    Join Date
    Sep 2018
    Age
    28
    Posts
    18
    I used an original 95 y body bin as a base for the tune installed. From some reading I found the fault is from the pcm to the speedo. Not trans to pcm so I’m not to worried about it at the moment. I believe that the 95 cars just talk to the ccm differently and that’s what may be causing my issue. Maybe lol. Idk
    Last edited by Lockdun1; 4 Days Ago at 09:21 AM.

  12. #27
    Fuel Injected!
    Join Date
    Oct 2013
    Posts
    893
    Yes, that code has nothing to do with the valve body or the VSS sensor. Did the speedometer work?

    The code is referring to a 4000 pulse per mile VSS output on the PCM used to drive the speedometer. It's a pull-down circuit, basically an open collector transistor. It needs the speedometer to have a pull-up resistor for it to work. You've probably lost that connection - maybe the pin pushed out of the connector or was damaged?

  13. #28
    Electronic Ignition!
    Join Date
    Sep 2018
    Age
    28
    Posts
    18
    Well my Speedo hasnít worked really since a week after I got the car. Dash just reads full values for everything needs to be repaired.I put original pcm in I get no vss fault at all itís only with the obd I one so Iím assuming itís simething to do with ccm but idk. Iíll look at a pinout and see if I can inspect the wire. The fault may be from me pulling the ccm fuses while datalogging and the wire gets no resistance while itís unplugged ya know .

  14. #29
    Fuel Injected!
    Join Date
    Mar 2013
    Posts
    445
    The ccm drives the digital display on the dash, so it is likely to not work when you pull the fuse.
    I suggest you make an idle traffic log with obd1 pcm and with the obd2 pcm and post it. I will see what is exchanged and can the obd1 pcm be hacked, to send the same data format.

    The vss should work, but I noticed that sensor pins are reversed. On 95 pin a goes to low, and pin b goes to high. On 96 pin a goes to high and pin b goes to low. The wires color coding is the same though.
    As a last resort you can switch the pins on the vss connector.

    EDIT
    I just realized that the code is for the vss output signal.

    The wire goes to ccm, cruise, radio and real time damping module, so it is not clear what happens with the signal when you turn the ccm off.
    Last edited by kur4o; 4 Days Ago at 01:38 PM.

  15. #30
    Electronic Ignition!
    Join Date
    Sep 2018
    Age
    28
    Posts
    18
    Without it plugged I don’t think it gets the signal resistance is needs and since I can’t datalog properly with it hooked up testing what the problem is well.... problematic. I’m pretty sure it’s that though when I first hook up the cable and pull the fuses it’s not shooting the code it only comes on later after they have been out for a bit . I have the new knock sensor in hand but it decided to rain today so getting to my buddy’s shop isn’t happening. Hopefully sometime this week and then it’ll be perfect. Afr is good ,Timing was dumbed down for 91 octane and I’m running 93 so even without me letting it pull timing at the moment it should be fine.

Similar Threads

  1. Tuner Pro XDF 1999-2000 F Body + Y Body
    By john h in forum OBDII Tuning
    Replies: 28
    Last Post: 09-18-2017, 07:04 PM
  2. F-body engine install to B-body
    By serge_an in forum GM EFI Systems
    Replies: 4
    Last Post: 09-22-2016, 04:51 AM
  3. 95 F-body Fuel Pump with 95 B-Body Engine/Tank
    By EPS3 in forum GM EFI Systems
    Replies: 7
    Last Post: 09-19-2016, 04:40 AM
  4. Replies: 0
    Last Post: 05-22-2016, 06:04 PM
  5. Replies: 0
    Last Post: 06-02-2015, 06:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •