Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Page 26 of 26 FirstFirst ... 16212223242526
Results 376 to 379 of 379

Thread: Uber-easy DIY USB ALDL Cable

  1. #376
    Carb and Points!
    Join Date
    Jan 2017
    Age
    30
    Posts
    2
    I am working on creating my own ALDL USB cable for my ZR-1. I bought a FTDI USB cable off Ebay and a 12 pin to 16 pin convertor cable. I cut that in half and am trying to hook up the FTDI USB cable to the 12 connector. Issue I see thus far is the 12 PIN connector cable only has 4 wires. They are BROWN, RED, ORANGE, YELLOW.Does anyone have any idea what wire is ground?

  2. #377
    Carb and Points!
    Join Date
    Mar 2017
    Posts
    5
    Quote Originally Posted by billymild View Post
    I am working on creating my own ALDL USB cable for my ZR-1. I bought a FTDI USB cable off Ebay and a 12 pin to 16 pin convertor cable. I cut that in half and am trying to hook up the FTDI USB cable to the 12 connector. Issue I see thus far is the 12 PIN connector cable only has 4 wires. They are BROWN, RED, ORANGE, YELLOW.Does anyone have any idea what wire is ground?
    you can check it with multitester right?

  3. #378
    Carb and Points!
    Join Date
    Jan 2017
    Age
    30
    Posts
    2
    Quote Originally Posted by simon blazer View Post
    you can check it with multitester right?
    I found this picture which helped out a ton.
    Attached Images Attached Images

  4. #379
    Carb and Points!
    Join Date
    Mar 2017
    Posts
    5

    no talk to ECU

    Hi guys, I've made 4 type of ALDL obd1 cable :

    1. with RS232 to TTL, Tx and Rx tied together on the TTL side, and connect into pin 9 (ALDL 16pin), cable found and functioning, passed cable test, but still cannot talk to ECU.

    2. with TTL to USB adapter (FTDI chip), Tx and Rx tied together on the TTL side, and connect into pin 9 (ALDL 16pin), cable found and functioning, passed cable test, but still cannot talk to ECU.

    3. Built 2 transistor interface, no cable found, no talk to ECU
    4, Built 1 transistor interface, no cable found, no talk to ECU

    It's seems tha my ECU not listening to them, but it's talk happily to GM tech 1 scanner for sure.

    What else I can do to make ECU talk to me? thanks for help.

    arduino_rs232.jpg


    Best,
    Simon
    Last edited by simon blazer; 4 Weeks Ago at 12:14 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •