Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Results 1 to 5 of 5

Thread: 165 ecm 5.0 runs best with MAF unplugged

  1. #1
    Fuel Injected! jameslleary's Avatar
    Join Date
    Apr 2011
    Location
    Patterson, Ca
    Posts
    269

    165 ecm 5.0 runs best with MAF unplugged

    Hey guys, I am looking at some diagrams, and I was wondering if anyone has a clue why it runs only with the MAF unplugged. Owner says he cant read a BCC on the on the memcal.
    I am wondering if someone may have messed with the wiring when it was in the donor car.
    Says he cant give it gas with it plugged in, just dies. runs rich too. any ideas?

  2. #2
    EFI GearHead ! EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    57
    Posts
    10,477
    I thought those only had a MAF and no MAP? So with the MAF unplugged he is running in Limp Home Mode? Does the check engine light come on blink and stay on till car is started then turn off? Probably have to clear codes now that he has run it without MAF first. Then CEL, then run it for awhile, then read codes. Then in end find a bad MAF sensor.

    Probably someone here to help you but going to have to do those things above. In the end ThirdGen.org is speciallty place for that ECM. But they will need more info that what you got... or a data log to see what's really happening. HTH!

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  3. #3
    Fuel Injected! jameslleary's Avatar
    Join Date
    Apr 2011
    Location
    Patterson, Ca
    Posts
    269
    He has followed GM's flow checks, and has replaced the MAF 3 times. Its a transplant into a sqarebody gm truck.

  4. #4
    Super Moderator
    Join Date
    Mar 2011
    Location
    Camden, MI
    Age
    28
    Posts
    3,026
    IIRC, when you unplug the MAF on those, they go into alpha-n mode(fueling based off of RPM and TPS).

    it does sound like a bad MAF, or at least bad MAF-related issue.
    1995 Chevrolet Monte Carlo LS 3100 + 4T60E


  5. #5
    EFI GearHead ! EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    57
    Posts
    10,477
    Transplant and seems MAF related so you mentioned wiring issue!

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •