Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Results 1 to 4 of 4

Thread: adx not working in APU mode

  1. #1
    Fuel Injected!
    Join Date
    Jan 2012
    Location
    Poland
    Posts
    91

    adx not working in APU mode

    Hi!

    I'm having problems connecting to 8D ECM using attached .adx file. It works fine when APU is set to pass-through mode (2nd switch outboard), but in APU mode it stops working. Other adx defs seem to work fine in APU mode.

    I have checked the com port data stream using sniffer software, and clicking "connect" with this adx selected generates NO traffic on com port! The emulator control buttons work correctly at the same time... I've been looking through the adx comparing to others but I can't find what may be different in this one so it refuses to send any data in APU mode... Any help will be appreciated!
    Attached Files Attached Files

  2. #2
    Fuel Injected! MQQN28's Avatar
    Join Date
    May 2016
    Location
    Melbourne Australia
    Age
    70
    Posts
    24
    Hi
    one thing to check is the flag values in the adx file
    <flags>0x10001</flags>
    <objectcount>120</objectcount>
    The most significant means here that it using a usb. if for instance using blue tooth it would be <flags>0x00001</flags>.
    <ADXCLISTENPACKET id="COMMAND0RE" idhash="0xE6B79C55" title="Mode 1 ALDL Dump Request Reply" flags="0x00000001">
    check these values in these commands. Im not fully up on these flag values.
    For how you are using this adx file maybe its a flag set wrong.

    You should really only edit this in tuner pro, but for just one bit value maybe.

    Something to look at.


    MOC
    Ford 28 Roadster Pick Up
    Ford Flathead 51 8BA. Balanced, ported,3/4 cam, Edelbrock 59A heads, C4 trans, 8" diff 3.55 narrowed 40mm /side.
    Fuel injection by Flatattack racing, 60mm Holden TB.
    ECM Delco 1227808 160 baud.

  3. #3
    Fuel Injected!
    Join Date
    Jan 2012
    Location
    Poland
    Posts
    91
    It starts to work when I uncheck "Align to header" option in Mode 1 response command.
    It's really strange, when "Align to header" is set, it won't execute the send command that is before the reply command that has the "aligh to header" option set...
    Attached Files Attached Files

  4. #4
    Fuel Injected! MQQN28's Avatar
    Join Date
    May 2016
    Location
    Melbourne Australia
    Age
    70
    Posts
    24
    Hi again
    This may help

    The listen packet is set to zero

    <ADXCLISTENPACKET id="CONNECTREPLY" idhash="0xCA39CA6C" title="Connect Reply" flags="0x00000004">
    <listentimeout>400</listentimeout>
    <packetbodylength>0</packetbodylength>
    <packetoffsetinbody>0</packetoffsetinbody>
    <packetsize>0</packetsize>
    <headerstring size="4">F45600B5</headerstring>
    </ADXCLISTENPACKET>

    The next listen packet has values, this may be worth looking at.
    I will be off line later today till mid January. I will be driving the southern states. I wont have laptop with me so I may not be able to reply back
    Ford 28 Roadster Pick Up
    Ford Flathead 51 8BA. Balanced, ported,3/4 cam, Edelbrock 59A heads, C4 trans, 8" diff 3.55 narrowed 40mm /side.
    Fuel injection by Flatattack racing, 60mm Holden TB.
    ECM Delco 1227808 160 baud.

Similar Threads

  1. - we're working on it :)
    By IndyPaceCar in forum Old School EFI
    Replies: 41
    Last Post: 08-10-2017, 09:28 PM
  2. tcc not working
    By bonnieclyde100 in forum GM EFI Systems
    Replies: 14
    Last Post: 10-01-2014, 09:31 AM
  3. Working on MPG
    By sciroc in forum GM EFI Systems
    Replies: 31
    Last Post: 09-15-2014, 07:11 PM
  4. BLM Learn is working
    By jim_in_dorris in forum GM EFI Systems
    Replies: 22
    Last Post: 10-23-2013, 10:31 AM
  5. Hello, working on a 1988 GTA
    By eseibel67 in forum Introductions
    Replies: 10
    Last Post: 04-16-2013, 08:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •