Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Page 3 of 6 FirstFirst 123456 LastLast
Results 31 to 45 of 83

Thread: What efi system is best for a 4.5 pfi cadillac engine7

  1. #31
    Fuel Injected! S.O.B.B.'s Avatar
    Join Date
    Nov 2017
    Location
    Ontario Canada
    Posts
    112
    1st.xdl
    Tunerpro rt data log from 7747 asdm on 4.5 engine with tbi and 4.3 injectors. Can someone please tell me if the xdl posted here is the correct format for someone on here to view it.thanks
    Last edited by S.O.B.B.; 12-17-2017 at 04:44 AM.
    Jeeper
    87 sjimmy 4.5L /nv1500/ 8.8 3.55 rear/disc brakes.

  2. #32
    Fuel Injected! S.O.B.B.'s Avatar
    Join Date
    Nov 2017
    Location
    Ontario Canada
    Posts
    112
    Hello Dave w.got the cable for my programmer.did the socket mod on the 7747.read the bin from stock chip.made a couple small adjustments.initial timing to 10.egr off.bpw to 145.burned that to sst27sf512 with the offset listed on moates site because I could not find specific info on that chip for gq4x.anyway it started first shot and ran.it seemed like the miss was worse.I put the 5.0 I injectors in and burned chip again bpw 131.worse.I tried 2 other burns.both were minor to the bpw.the one I drove to work in bpw set at 149.it feels better mid throttle now but not as strong low end as b4.blm at idle is 128.driving in 5th at 2200 rpm its 160-170.so I have lots to learn.but this is all new to me and I'm loving it.so cool to be able to do.wishing I got into this year's ago.thanks to all the info on this site it's made learning a lot easier.now I have to look at my logs and see the changes I made after each burn.try to figure what is needed.
    Last edited by S.O.B.B.; 12-19-2017 at 08:20 PM.
    Jeeper
    87 sjimmy 4.5L /nv1500/ 8.8 3.55 rear/disc brakes.

  3. #33
    Fuel Injected! S.O.B.B.'s Avatar
    Join Date
    Nov 2017
    Location
    Ontario Canada
    Posts
    112
    Dave w or anyone else that knows can u please point me the right direction. I'm using the large cap hei distributor.the system I'm using used a small cap distributor. I see 2 different spark latency tables for the large cap and both are different than what's on the factory chip that was small cap.which table should I be using.any help is appreciated
    Jeeper
    87 sjimmy 4.5L /nv1500/ 8.8 3.55 rear/disc brakes.

  4. #34
    Fuel Injected! uncabob's Avatar
    Join Date
    Jan 2016
    Age
    81
    Posts
    120
    Some good info over at 3rdgen on spark latency for large cap HEI.

    Bob
    Last edited by uncabob; 12-20-2017 at 09:00 AM. Reason: added info
    Don't force it, get a bigger hammer!

  5. #35
    Fuel Injected! S.O.B.B.'s Avatar
    Join Date
    Nov 2017
    Location
    Ontario Canada
    Posts
    112
    Thanks Bob. I was reading on tgo about it last night.I kind of understand what it is but I don't see what reason for which setting is used on which distributor. I copied the whole latency table and burned that this morning. Could barely drive up the road.but like a dumb ass I changed more than one thing.I also copied the timing table for a corvette that I got off superchevy.so I'm gonna try the other latency table that I didn't try.that will be the 3rd table.I'm gonna try to get me a 2240 caddy ecm and read the chip so I can copy a few tables from that because I don't think any of the swirl port head setting work on this engine.it's more like a pre efi sbc engine.I do have most of the stock 4.5 engine specs so I can calculate things but my lack of experience here is making it a little difficult. I had originally started and ran this with a small cap grafted onto the top of the oe caddy distributor. But the phase was off.so I made it adjustable and put a hole in a old cap to get it set right.it had pretty much the same issue.so I switched to the caddy distributor and icm.it's different but feels like the small cap did when the phase was off.with the large cap I have no way to cut a hole to see where it's firing. Leaves me guessing till I get the read from a caddy chip.I'll keep trying.thanks
    Last edited by S.O.B.B.; 12-20-2017 at 01:56 PM.
    Jeeper
    87 sjimmy 4.5L /nv1500/ 8.8 3.55 rear/disc brakes.

  6. #36
    Fuel Injected! S.O.B.B.'s Avatar
    Join Date
    Nov 2017
    Location
    Ontario Canada
    Posts
    112
    I was just looking at some logs.I just noticed on the list view it says prom error.I get no check engine light.no codes.light does work. I'm using gq4x and I put chip offset start address at 00F000.can anyone tell me if that offset is correct when writing to a sst27sf512 chip for use where a 2732a chip was.thanks
    Jeeper
    87 sjimmy 4.5L /nv1500/ 8.8 3.55 rear/disc brakes.

  7. #37
    Fuel Injected! S.O.B.B.'s Avatar
    Join Date
    Nov 2017
    Location
    Ontario Canada
    Posts
    112
    Ok got some better results this last try for my drive to work.still says error beside prom but unsure of why.I played more with timing table.bpw at 148 the oe setting.ve table a bit.and this pic is the spark latency corretion I put in.Screenshot_2017-12-20-05-26-53.jpgI need to do more timing table work for lower rpm range.ad lots.blms are around 120 to 140 when on the gas but at cruise at 55mph blm at 160 plus.I notice my iac is 25 or so hot idle.145 key on engine off.but driving the number is around 80 until I take my foot off.I'm guessing that's letting lots of extra air in when unneeded and giving the lean condition.it's almost as though as tps and rpm rise so does iac. Is that setting of iac or faulty sign.anyone?20171220_210933.jpg20171220_205342.jpg20171220_210901.jpg
    Last edited by S.O.B.B.; 12-20-2017 at 08:48 PM.
    Jeeper
    87 sjimmy 4.5L /nv1500/ 8.8 3.55 rear/disc brakes.

  8. #38
    Super Moderator dave w's Avatar
    Join Date
    Feb 2011
    Posts
    3,699
    The attached $42 .xdl files are from reasonably good running engines.

    dave w
    Attached Files Attached Files

  9. #39
    Fuel Injected! S.O.B.B.'s Avatar
    Join Date
    Nov 2017
    Location
    Ontario Canada
    Posts
    112
    Thanks for the files Dave w.will try to get a look today.last night I downloaded 6870 1F (85 tpi) bin mostly because it's s large cap distributor. But the sa table uses load instead of map and I'm unsure of load numbers or if they compare to map numbers or if that just isn't something I can do. Looked at lots of other timing graphs and even the original from the 7747 asdm.I may try to put the large cap latency into that and start from there.not sure yet.after I get to see the files I'll go from there. Thanks
    Last edited by S.O.B.B.; 12-21-2017 at 03:05 PM.
    Jeeper
    87 sjimmy 4.5L /nv1500/ 8.8 3.55 rear/disc brakes.

  10. #40
    Fuel Injected! S.O.B.B.'s Avatar
    Join Date
    Nov 2017
    Location
    Ontario Canada
    Posts
    112
    Hello Dave w.I have a few questions I'm sure u'd be able to help with.after lots of playing with different timing tables Im still not quite running right but by far the best yet.I'm using a large cap hei from an 89 4.5 on the 90 4.5 engine.I also changed the latency to the higher numbered set up and that really woke it up.my egr and air is disabled.on Temps maxed.the main spark advance bias.should I zero this so it's not taking 9.84 away.the initial is set at 10.2 and at balancer I'm at about 15 to 16 to get it to run decent.when I Rev it and watch the timing light it sure does not seem to get much more than about 28 to 30 .my timing table has lots of cells over 40 so I'm unsure of how to correct this.the old latency numbers I had in were from I beleive a camaro.with that I needed to run around 20 on the balancer to run better.it's the most responsive and has good pull but lower rpms and high map it seems like it's missing timing.do most timing tables taper off lower after 50 to 60 kpa map.I have not had the chance to log the current set up as it's been too cold.is there an equasion to convert lv8 load numbers into kpa map numbers. thanks
    Last edited by S.O.B.B.; 12-28-2017 at 04:57 PM.
    Jeeper
    87 sjimmy 4.5L /nv1500/ 8.8 3.55 rear/disc brakes.

  11. #41
    Super Moderator dave w's Avatar
    Join Date
    Feb 2011
    Posts
    3,699
    I don't have a good answer, maybe look at the Spark Parameters for a Large Cap HEI from a 1990 Corvette TPI : http://www.gearhead-efi.com/Fuel-Inj...Information-8D

    You could also compare the Spark Parameters for a Small Cap HEI from a 1990 Camaro TPI using the compare feature in TunerPro. http://www.gearhead-efi.com/Fuel-Inj...Information-8D

    dave w

  12. #42
    Fuel Injected! S.O.B.B.'s Avatar
    Join Date
    Nov 2017
    Location
    Ontario Canada
    Posts
    112
    430 am b4 work I decided to do a quick burn.zeroed out the spark advance bias.that made a huge difference on my drive to work.too much timing now.but now I know I wasn't getting what I was asking for and my sa table and distributor timing will need resetting to get this corrected.I will be trying the 89 tpi sa table to see what that does.took lots of playing around and reading but I think I'm getting the hang of it a bit better now thanks to all the helpful people and info on this site.gives me a little more confidence in getting the 7427 pfi going.thanks to all
    Jeeper
    87 sjimmy 4.5L /nv1500/ 8.8 3.55 rear/disc brakes.

  13. #43
    Fuel Injected! S.O.B.B.'s Avatar
    Join Date
    Nov 2017
    Location
    Ontario Canada
    Posts
    112
    ARPC 91 C-K Truck 5.0TBI 5 speed (88vette32 sa table).bin
    asdn 88ck 5.0 5speed (arap sa table modded).bin

    These are the two bins I'm playing with.the first one I have not yet tried but it's burned and ready as soon as i can clear snow and reset timing.the second one is what Ive been tweaking for a week.if anyone can take a look at them and give me some advice that would be great.tell me if I have done things I shouldn't have or if i didn't do something I should. Please don't be too harsh.I'm just a beginner. Thanks.data logs to follow.just haven't been logging because of the weather.
    Last edited by S.O.B.B.; 12-30-2017 at 05:04 AM.
    Jeeper
    87 sjimmy 4.5L /nv1500/ 8.8 3.55 rear/disc brakes.

  14. #44
    Fuel Injected! S.O.B.B.'s Avatar
    Join Date
    Nov 2017
    Location
    Ontario Canada
    Posts
    112
    Well neither of those worked that great.ive since got it running better. I got the other chips I ordered and they do work.I was worried they'd be fake.so I ordered 10 more and a few zif sockets to make this a little faster and easier when it's freezing out.its hard to not damage the chip legs when ur fingers are numb.but at least I'm learning more about reading the data logs and making adjustment based off what the log says.mostly in the timing.reduce when I see knock and add where the studded occurs.it's been getting better but I can't seem to get my blm and int in the correct range.not far off when on the throttle but goes lean while cruising. Beginning to think I have a vacuum leak.my 5th gear is pretty much toast now so I'm hopi g the trans will last till warm weather otherwise I'll be swapping back to 700 r4 in the freezing cold. So that sucks but the tuning just keeps getting g better.pretty awesome what can be done on a low budget.
    Jeeper
    87 sjimmy 4.5L /nv1500/ 8.8 3.55 rear/disc brakes.

  15. #45
    Fuel Injected! S.O.B.B.'s Avatar
    Join Date
    Nov 2017
    Location
    Ontario Canada
    Posts
    112
    Well I've been doing tuning almost daily and have reached a point where I can't get better blms. I did some reading and thought to double check what the injector numbers were.ah the importance of knowing what u have. I had a set from a 4.3 and they were indeed different numbers between the two.so I put a tbi 4.5 cadillac set in it.that was a vast improvement.I also put the spark plug gap from 45 I had it at to 60 the engine calls for.also found a cracked insulator on one plug so replaced it. But I'm still showing lean in the top and my ve table highest is 96.ve2 all set to 3.6 so total is never over 100.my bpw is at 153.my fuel pressure is 11psi rock steady.I'm looking for advice on what to do.I have a set of 5.0 injectors and wonder if I should try those and drop my bpw to 133 and scale back ve table and increase bpw from there as needed.in my $42 bin the injector bias is set at the factory .4ms.I have not changed that setting at all yet and wonder if I should be when large bpw changes occur.the factory bin bpw was 148.I've been as low as 133 and 153 the highest.blms at 30 kpa map are in range but once the map kpa rises above 30 I'm getting 130s 140s 150s on blm.any advice is much appreciated.
    Jeeper
    87 sjimmy 4.5L /nv1500/ 8.8 3.55 rear/disc brakes.

Similar Threads

  1. New to Forum, wanting to EFI my Cadillac
    By HotRodCadillac in forum Introductions
    Replies: 1
    Last Post: 07-14-2015, 08:48 PM
  2. is there a program for the 1994 cadillac deville
    By swat455 in forum GM EFI Systems
    Replies: 0
    Last Post: 04-21-2015, 11:53 AM
  3. 68 Cadillac TBI
    By blue68deville in forum Gear Heads
    Replies: 8
    Last Post: 10-30-2014, 04:02 PM
  4. Possible 500 Cadillac Project?
    By Lextech in forum GM EFI Systems
    Replies: 2
    Last Post: 10-22-2013, 07:44 PM
  5. Cadillac 500 to TBI
    By Avalanche in forum GM EFI Systems
    Replies: 33
    Last Post: 03-07-2012, 05:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •