Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Page 1 of 2 12 LastLast
Results 1 to 15 of 23

Thread: red devil blue tooth problem

  1. #1
    Fuel Injected!
    Join Date
    Apr 2015
    Posts
    25

    red devil blue tooth problem

    Hello
    I am having problems with the red devil blue tooth adapter.

    I can get data when I have my devices hard wired so my ADX file works.

    blue tooth pairs with no problem.

    Using the red devil blue tooth i get no communications with ecm.

    I also changed the default baud rate in the adx file to 9600 and the same thing, no communications with ecm.

    I don't know what else i can try so I am stuck. No word from the red devil web sight.

    Any ideas would be great. Thanks
    1993 Chevy Blazer TBI Vortec long block 5.7
    16168625 BDJZ 46mm TB 18 PSI fuel
    Camshaft, Hydraulic Roller Tappet, Advertised Duration 288/308, Lift .431/.451
    Chevrolet Performance Vortec TBI Intake Manifold
    shorty's, y-pipe and 3" full boar muffler

  2. #2
    Electronic Ignition! MQQN28's Avatar
    Join Date
    May 2016
    Location
    Melbourne Australia
    Age
    70
    Posts
    19
    Dom
    If you have no communication with the ECM it wont work period. What programme are you using? I'm just starting with this and my whole system is custom and I had some problems getting it going.
    I'm using the red devil with ALDL droid blue toothed to a tablet or android phone. My first problem was the socket was wired wrong, my mistake. I had 160 baud going to the 8192 pin E and M reversed. Corrected this and got communication. Now my problem is the ADX file.

    You need to look at the flashing led to determine the status of the unit. I'm not sure but your ADX file that worked with the other set up may not be right for this.
    I'm getting data in but it wrong. I changed the same setting you did as well to 9600.

    The other thing also is you may have to put a 10K resistor between pin A and B. This may be taken care of when you hard wire it, but I have to have the Resistor.

  3. #3
    Fuel Injected!
    Join Date
    Apr 2015
    Posts
    25
    MQQN28 Thanks for the reply
    The program i am using, ALDLdroid and Turner pro RT, the same adx file works for both devices and programs just not over the red devil. Green blinking light when the blue tooth connects.
    I could try the 10k resistor easily.
    1993 Chevy Blazer TBI Vortec long block 5.7
    16168625 BDJZ 46mm TB 18 PSI fuel
    Camshaft, Hydraulic Roller Tappet, Advertised Duration 288/308, Lift .431/.451
    Chevrolet Performance Vortec TBI Intake Manifold
    shorty's, y-pipe and 3" full boar muffler

  4. #4
    Fuel Injected!
    Join Date
    Apr 2015
    Posts
    25

    Up date

    I tried the 10k resistor between pin A and B. with engine running, blue tooth paired ALDLdroid not connected and the light on the red devil blinks red and when connected the red blinking turns solid blue and the service engine light turns on.

    No resistor, Red devil light with no connection blinking green and turns solid blue when connected.

    Blue light must be a bad thing. Still no data, not communicating with ECM.
    thinking adx file,
    1993 Chevy Blazer TBI Vortec long block 5.7
    16168625 BDJZ 46mm TB 18 PSI fuel
    Camshaft, Hydraulic Roller Tappet, Advertised Duration 288/308, Lift .431/.451
    Chevrolet Performance Vortec TBI Intake Manifold
    shorty's, y-pipe and 3" full boar muffler

  5. #5
    Fuel Injected!
    Join Date
    Dec 2016
    Location
    Colorado
    Age
    33
    Posts
    86
    Have you not heard back from Red Devil? I have heard their cust service is very lacking. I got my bluetooth device from John at 1320 electronics. Excellent customer service and he is on this forum as well.

  6. #6
    Fuel Injected!
    Join Date
    Apr 2015
    Posts
    25
    Nothing from red devil. Wasted $80
    1993 Chevy Blazer TBI Vortec long block 5.7
    16168625 BDJZ 46mm TB 18 PSI fuel
    Camshaft, Hydraulic Roller Tappet, Advertised Duration 288/308, Lift .431/.451
    Chevrolet Performance Vortec TBI Intake Manifold
    shorty's, y-pipe and 3" full boar muffler

  7. #7
    Fuel Injected!
    Join Date
    Apr 2015
    Posts
    25
    Not giving up, Samsung Phone S8 and Samsung tablet E could also be the prob. just grasping at this point.
    1993 Chevy Blazer TBI Vortec long block 5.7
    16168625 BDJZ 46mm TB 18 PSI fuel
    Camshaft, Hydraulic Roller Tappet, Advertised Duration 288/308, Lift .431/.451
    Chevrolet Performance Vortec TBI Intake Manifold
    shorty's, y-pipe and 3" full boar muffler

  8. #8
    Electronic Ignition! MQQN28's Avatar
    Join Date
    May 2016
    Location
    Melbourne Australia
    Age
    70
    Posts
    19
    Dom
    been away for a few days.

    This seems to be where I was at one stage. The red devil is not seeing the data stream. My problem was I reversed the 160 and 8192 terminals when I wired up the ALDL socket my ECM an 808 160 baud. But this should not be your problem. The other thing I have just read is that the RED Devil does not like a pin on both E (160) and M (8192) of the socket. I'm not familiar with your ecm I take it is 8192.

    On my system I know the data stream is running because the CEL light flashes, this seems to be what you get with the 10K resistor. The 10K resistor will start the data and can be removed. With 8192 it would appear to be full on.

    I'm looking for some information I have on the red devil showing the led status, I have missed placed it.

    I'm at the stage where I am receiving data but its not going where it should, I'm playing with the adx file.

    Are you able to check if the data stream is getting to the right pin?

    The other thing I'm using a Samsung S8 also and it seems to be working.
    Last edited by MQQN28; 08-08-2017 at 02:48 PM.

  9. #9
    Fuel Injected!
    Join Date
    Apr 2015
    Posts
    25
    MQQN28
    The pin that is sending data is M at 8192, if I use a wire adapter every thing works good , I would rather not have wires. No pin E.
    Timm Becker got back to me asking for tuck info, and he said that there is already a 10k resistor built into it.
    I looked at the info on the disk that came with it and 8192 would be a blue light with some other color blinking every few seconds, I get that just no data.
    ALDLdroid after pressing the connect button i get a red bar on the bottom of the screen with no response from ecm.
    1993 Chevy Blazer TBI Vortec long block 5.7
    16168625 BDJZ 46mm TB 18 PSI fuel
    Camshaft, Hydraulic Roller Tappet, Advertised Duration 288/308, Lift .431/.451
    Chevrolet Performance Vortec TBI Intake Manifold
    shorty's, y-pipe and 3" full boar muffler

  10. #10
    Electronic Ignition! MQQN28's Avatar
    Join Date
    May 2016
    Location
    Melbourne Australia
    Age
    70
    Posts
    19
    DOM
    I started mine up last night.

    First you are right about the 10k resistor it will start with the built in one, I don't have to kick start it. When it connects the led is blue. Then it flashes green and red when the data starts.
    At this point it should start for you. One other thing you could check is if you have an XDF file in the XDF directory. ALDL Droid checks this at start up. I know this seems strange as you only want to see it connect at the moment. But I just remembered that I had to put an XDF file into that directory. When mine starts I get a comment that the XDF file it could not be parsed properly. This could be why I'm still getting wrong data.

    Next you could try this.
    Try ALDL Scan app. Its easily obtained from play store.
    It connects to the RED devil ok. From the menu select Vehicle protocol (ALDL file) pick one of the pre installed ones that suits you. Then select Adapter. Then press view data.
    It should start when you touch the arrows icon.
    This programme uses less baggage but at least you can see if the red devil is working.

    What ever my problem is it is the same with both programs. Next step is to check my wiring again.

  11. #11
    Electronic Ignition! MQQN28's Avatar
    Join Date
    May 2016
    Location
    Melbourne Australia
    Age
    70
    Posts
    19
    Dom

    Another thing to try is check if the RS232 box is checked. When connecting with a cable this is checked, you may not need it with the box.
    Look in the ADX file at the Header for <flags>0x10001</flags> or <flags>0x01</flags>. If its like this then the RS232 box is checked. When unchecked it will look like this <flags>0x10000</flags>.

    Its probably better to edit this in tuner pro, when you uncheck it you can save the file with a different name.
    Ford 28 Roadster Pick Up
    Ford Flathead 51 8BA. Balanced, ported,3/4 cam, Edelbrock 59A heads, C4 trans, 8" diff 3.55 narrowed 40mm /side.
    Fuel injection by Flatattack racing, 60mm Holden TB.
    ECM Delco 1227808 160 baud.

  12. #12
    Fuel Injected!
    Join Date
    Apr 2015
    Posts
    25
    MQQN28

    Thanks , RS232 Echo box was checked, I unchecked it, I will give that a try and let you know.

    Still nothing from red devil.

    Edit
    I tried with the Echo box unchecked and still the same, I might just have to cut my loss and buy the other one and hope I don't have the same problem, that would bite
    Last edited by Dom; 08-28-2017 at 05:57 PM.
    1993 Chevy Blazer TBI Vortec long block 5.7
    16168625 BDJZ 46mm TB 18 PSI fuel
    Camshaft, Hydraulic Roller Tappet, Advertised Duration 288/308, Lift .431/.451
    Chevrolet Performance Vortec TBI Intake Manifold
    shorty's, y-pipe and 3" full boar muffler

  13. #13
    Electronic Ignition! MQQN28's Avatar
    Join Date
    May 2016
    Location
    Melbourne Australia
    Age
    70
    Posts
    19
    Dom

    My Red devil is finally working, but not without fixing some faults.

    Your comment about the 10k resistor got me moving. I had it wired to a switch near the ALDL plug which was mounted behind the seat in the model A because this was close to the ECM, not a good place for the aldl. I have moved it to the equivalent of under the dash, which is under the tank in the model A. I got rid of the switch. If I left it on it was putting 2 10k resistors in parallel when the red devil switched, this wasn't sending the right mode wrong adx file also. The other problem was in extending the cables I damaged the data wire and had to find that little error. I am now getting data on Samsung S8 with ALDL Droid, so that works.

    I just recently found an ADX file on the forum ($42-1228062-V1) that with modification will suit my $5D 160 baud.

    Your problems may just be some editing in the ADX file for the red devil. When you connect the app you press connect to ECU this makes the red devil connect the 10K resistor to start the data stream.
    In the ADX file you are using for the cable it has other commands to start the data stream, you may not need these commands.

    <ADXCLISTENPACKET id="160BAUD" idhash="0xD05BBA9A" title="Data Transfer" flags="0x00000009">
    <desc>Command to hook up to ECM and get data!</desc>
    <listentimeout>400</listentimeout>
    <packetbodylength>0</packetbodylength>
    <packetoffsetinbody>0</packetoffsetinbody>
    <packetsize>20</packetsize>
    </ADXCLISTENPACKET>

    This is a the only send command. As you are 8192 the packet info will be different. You could try a few edits. I think you only have to get the ADX right.

    I also found a good description of the data stream for 160 baud $5D and will now edit up the adx. I just got the RPM parameter going first and starting to add the rest.

    Don't give up keep going. At least you have a stock system, mine is all modified.

    MOC
    Ford 28 Roadster Pick Up
    Ford Flathead 51 8BA. Balanced, ported,3/4 cam, Edelbrock 59A heads, C4 trans, 8" diff 3.55 narrowed 40mm /side.
    Fuel injection by Flatattack racing, 60mm Holden TB.
    ECM Delco 1227808 160 baud.

  14. #14
    Fuel Injected!
    Join Date
    Apr 2015
    Posts
    25
    MQQN28
    I don't know where to fine that string of code. This is a little over my head.
    1993 Chevy Blazer TBI Vortec long block 5.7
    16168625 BDJZ 46mm TB 18 PSI fuel
    Camshaft, Hydraulic Roller Tappet, Advertised Duration 288/308, Lift .431/.451
    Chevrolet Performance Vortec TBI Intake Manifold
    shorty's, y-pipe and 3" full boar muffler

  15. #15
    Electronic Ignition! MQQN28's Avatar
    Join Date
    May 2016
    Location
    Melbourne Australia
    Age
    70
    Posts
    19
    Have a go at putting up your ADX file.
    Ill have a look. I'm not an expert but I may be able to come up with something.

    Is any one else running 16168625 BDJZ to red devil and have an ADX file for this.

    edit Found one right where it should be let me have a look and get back post yours any way. just for a look
    Last edited by MQQN28; 09-05-2017 at 07:22 PM.
    Ford 28 Roadster Pick Up
    Ford Flathead 51 8BA. Balanced, ported,3/4 cam, Edelbrock 59A heads, C4 trans, 8" diff 3.55 narrowed 40mm /side.
    Fuel injection by Flatattack racing, 60mm Holden TB.
    ECM Delco 1227808 160 baud.

Similar Threads

  1. 7730 ecm 40 tooth tone ring
    By misterpat in forum GM EFI Systems
    Replies: 9
    Last Post: 05-12-2017, 05:04 PM
  2. Red/blue connectors
    By myburb in forum GM EFI Systems
    Replies: 0
    Last Post: 10-16-2015, 06:56 PM
  3. Looking for a disassembly of 12613246 OS Green Blue PCM
    By james_adams2006 in forum GM EFI Systems
    Replies: 2
    Last Post: 07-01-2015, 05:10 AM
  4. 40 tooth vss sensor gap/clearance
    By JeepsAndGuns in forum Gear Heads
    Replies: 7
    Last Post: 01-06-2015, 05:11 PM
  5. Strange issue using red devil river and aldl droid
    By davidgoodin in forum GM EFI Systems
    Replies: 11
    Last Post: 11-20-2014, 05:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •