Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Results 1 to 2 of 2

Thread: Dimented24x7's LS1 flash tool issue

  1. #1
    Fuel Injected!
    Join Date
    Jan 2012

    Dimented24x7's LS1 flash tool issue

    Hi, I'm using AVT-852 cable with Dimented's LS1 flash tool. So far it was working OK, but I got into trouble with one PCM.

    It is 411 pcm from a truck with 9381344 operating system originally. I read the stock bin with no problems.
    Then I updated the PCM using Tech 2 SPS to the newest bin for the same VIN. It changed OS to 12205612. No problem reading/writing with LS1flash tool after that.

    Then I wanted to get a virgin calibration for another car I'm tuning, I programmed the PCM with a VIN for 2002 Camaro SS with 12212156 OS. Everything went OK and the PCM is working in the car, but after that SPS flash I can't start programming session using Dimented's tool.
    After I click "start programming session" the log says "Skipping security access" and then gives a timeout error. When this was working correctly, it would never log "Skipping security access", only get seed and send key.

    Has enyone encountered simmilar issue?

    I tried to reprogram it again with SPS, but it didn't help. I even went back to the original VIN with truck OS, but still the same result.

    I think that must be something with SPS changing the security access when programming...

    Thanks for any help!
    Last edited by dzidaV8; 07-13-2017 at 01:49 PM.

  2. #2
    Fuel Injected!
    Join Date
    Jan 2012
    OK, it turned out the Dimented's tool has a bug. When PCM returns zero seed (0x0000) it means that it's already unlocked. It seems that for some reason the SPS programming after full flash leaves the PCM permanently unlocked.
    After the zero seed the flash program should proceed to upload the flash interface without sending key, and the log says that it tries to do that.
    The bug is that the tool never sends the mode 34 message in that case, but waits for the PCM mode 34 response.

    I resolved this issue with a workaround - I connected ELM327, and when the tool was waiting for mode 34 response ("Skipping security access" in the log) I sent message 6C 10 F0 34 00 09 D6 FF 83 00 - a message that is normally sent after unlockig the PCM.

Similar Threads

  1. LS1 Flash Tool Released
    By antus in forum OBDII Tuning
    Replies: 113
    Last Post: 02-05-2016, 10:38 AM
  2. $EE Flash tool progress
    By steveo in forum GM EFI Systems
    Replies: 112
    Last Post: 12-17-2015, 08:30 AM
  3. Group Buy for LS1 Flash Tool AVT 852 cable!
    By EagleMark in forum OBDII Tuning
    Replies: 73
    Last Post: 03-02-2014, 01:11 PM
  4. Replies: 8
    Last Post: 02-11-2014, 08:25 PM
  5. Memcal Flash Tool
    By EagleMark in forum GM EFI Systems
    Replies: 6
    Last Post: 01-21-2013, 07:26 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts