Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Results 1 to 8 of 8

Thread: 1991 TBI Tuner Pro RT Data Analysis

  1. #1
    Carb and Points!
    Join Date
    Mar 2017
    Posts
    5

    1991 TBI Tuner Pro RT Data Analysis

    I have a 1991 Silverado with the 5.7 TBI engine. I have Tuner Pro RT and have logged a few (one for sure, not sure what happened to the other) data streams while driving. Generally things seem about as expected except that whenever my throttle opening gets up near 50% my vacuum goes to zero. Maybe that's normal but it seems to drastic. Idle vacuum is good, transmission shift points seem about right. Overall the truck seems like it is dragging an anchor and fuel economy stinks (10 mpg empty, 8 towing a trailer). Transmission will unlock with just about any throttle or load input, and it will downshift out of OD to maintain 70 mph empty (worse with the trailer).

    Any thoughts appreciated.

  2. #2
    Carb and Points!
    Join Date
    Mar 2017
    Posts
    5
    I rearranged the dash on my Tuner RT Pro and one of the gauges I added was spark advance. When I play back my data file it looks like I am not getting any spark advance at any time. That may explain a lot about the performance (or lack there of). I plan to look at the distributor but any recommendations on what to look for would be appreciated.

  3. #3
    Fuel Injected! jim_in_dorris's Avatar
    Join Date
    Dec 2011
    Posts
    760
    the spark advance gauge will only work if you have enabled in on the chip, it is a patch. Things to look for would be fuel pressure, spray pattern of your injectors (if only 1 is working it will run very poorly off idle). what do you spark plugs look like? is it running rich? or lean?
    Square body stepsides forever!!!

  4. #4
    Carb and Points!
    Join Date
    Sep 2016
    Posts
    9
    Check your MAP sensor for a dead spot. Use a vacuum hand pump and watch the readings on Tuner Pro.
    0 in. Hg ...... 4.7 Volts.
    5 in. Hg ...... 3.9 Volts.
    10 in. Hg .... 3.0 Volts.
    20 in. Hg .... 1.1 Volts.

  5. #5
    Carb and Points!
    Join Date
    Mar 2017
    Posts
    5
    erjbsa - thanks I will check that out.

    Jim - Can I enable the chip in my std. production ECU with a patch to provide the advance gauge function? If so where is the patch available, and how do I write it into the ECM without changing anything else?

    FYI, I did confirm that the timing is moving with rpm using a timing light. I think my base timing was a little retarded so I reset to "0" with the timing set wire disconnected. However, it would be nice to know that the timing is doing as I am running down the road.

  6. #6
    Fuel Injected! jim_in_dorris's Avatar
    Join Date
    Dec 2011
    Posts
    760
    Unless I am wrong, you have a 7747 ecm which is a $42 mask. The patch was put into the tunerpro rt definition file by eagleMark. Look for the patch at the top of the file in tunerpro. You will have to burn a chip to get it to work.
    Square body stepsides forever!!!

  7. #7
    Carb and Points!
    Join Date
    Mar 2017
    Posts
    5
    I agree that I should have the 7747 ECM (not sure what I actually have given the lack of vehicle history) but I am using the $85 mask. I believe the $42 is for the 5.0 L and I have the 5.7 L. I am not planning to burn a chip so I will forego capturing timing advance, at least for now.

    Thanks

  8. #8
    Fuel Injected! jim_in_dorris's Avatar
    Join Date
    Dec 2011
    Posts
    760
    no, $42 also has 350 bins, I run it in my truck. If you are truly running $85, then you have a 7060 ecm which is for 4l80E transmissions. If you have a 7747 and are using the $85 adx and xdf, you data will be wrong. totally different masks. the ECM is behind the glovebox I think. you should be able to see the sticker without removing it. Since you are not tuning, just trying to see what is happening, I wouldn't remove it right now.
    Square body stepsides forever!!!

Similar Threads

  1. '94 LT1 EEHack analysis using WB
    By babywag in forum GM EFI Systems
    Replies: 15
    Last Post: 11-16-2016, 02:26 PM
  2. Astro 4.3L V6 TBI (1991)
    By pbob65 in forum Introductions
    Replies: 1
    Last Post: 12-23-2015, 05:25 PM
  3. Corvette c4 1991 looking a bin
    By discovery1920 in forum GM EFI Systems
    Replies: 2
    Last Post: 07-28-2015, 06:38 PM
  4. Data logging with tuner pro and auto prom question
    By MxRace75 in forum GM EFI Systems
    Replies: 18
    Last Post: 09-24-2014, 09:35 PM
  5. Data acquisition set up for Tuner Pro
    By POZE in forum TunerPro Tuning Talk
    Replies: 8
    Last Post: 04-02-2012, 02:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •