Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Page 1 of 2 12 LastLast
Results 1 to 15 of 20

Thread: TBI 16168625 to LT1 16188051 Swap No TCC lock up??

  1. #1
    Fuel Injected! bybyc5's Avatar
    Join Date
    Feb 2013
    Location
    NE, Tennessee
    Age
    62
    Posts
    73

    TBI 16168625 to LT1 16188051 Swap No TCC lock up??

    Been searching for a while here with no luck... All is working really well and runs great, save for NO TCC lock up.

    My 1993 K1500/4L60E now has a basically stock LT1 motor now ( 383 with a 4x4 torque cam ), I used a basically stock F-body harness.
    I have used a couple different bin files for a 1994 LT1 Automatic, knowing my 93 4L60E is NOT PWM. I have checked and rechecked all my pin/connector locations and all is good as far as I can see. All my Bat+, Key+, and Ground circuits are good.

    Some of the stock inputs from the F-body harness I have not hooked up, because, #1 there is no place to use these on my truck AND #2....I don't know what some of them do.

    I can while driving ground the TCC lock up wire and I do get TCC lock up. So for some reason the PCM is not commanding lock up?

    Inputs/Outputs that are NOT connected: >>>

    1- PNP Grounded or not, still no TCC lockup. No PNP in my truck, the neutral safety feature is not electrical. The key wont turn to start if your anywhere other than neutral or Park.

    2- EBTCM TP...Not sure what this is or how it works?

    What I do have wired up and working.

    Brake switch circuit is good.

    VSS to and from PCM is good, my speedometer is working perfect. ( I have other questions about this, and getting my cruise control working again....just not as important as TCC Lock up. )

    What qualifiers does the 16188051 need to ground pin 11 Tan/BK wire in PCM BLUE connector?

    Sure would like the TCC working...

    Thank you!!

    James
    Last edited by bybyc5; 03-05-2017 at 06:19 AM. Reason: edited sig
    04 Lightning Pullies n Tune CAI
    96 Formula WS-6 m6 383 LE3-Heads/GM847/N2O/ Ford 9" 4:33/Sus Work/Stickies/TunerProRT
    93 K1500 383 LT1 with Low RPM 4x4 torque cam

  2. #2
    Fuel Injected!
    Join Date
    Feb 2013
    Location
    Euless, TX
    Posts
    1,460
    Quote Originally Posted by bybyc5 View Post
    Been searching for a while here with no luck... All is working really well and runs great, save for NO TCC lock up.

    My 1993 K1500/4L60E now has a basically stock LT1 motor now ( 383 with a 4x4 torque cam ), I used a basically stock F-body harness.
    I have used a couple different bin files for a 1994 LT1 Automatic, knowing my 93 4L60E is NOT PWM. I have checked and rechecked all my pin/connector locations and all is good as far as I can see. All my Bat+, Key+, and Ground circuits are good.

    Some of the stock inputs from the F-body harness I have not hooked up, because, #1 there is no place to use these on my truck AND #2....I don't know what some of them do.

    I can while driving ground the TCC lock up wire and I do get TCC lock up. So for some reason the PCM is not commanding lock up?

    Inputs/Outputs that are NOT connected: >>>

    1- PNP Grounded or not, still no TCC lockup. No PNP in my truck, the neutral safety feature is not electrical. The key wont turn to start if your anywhere other than neutral or Park.

    2- EBTCM TP...Not sure what this is or how it works?

    What I do have wired up and working.

    Brake switch circuit is good.

    VSS to and from PCM is good, my speedometer is working perfect. ( I have other questions about this, and getting my cruise control working again....just not as important as TCC Lock up. )

    What qualifiers does the 16188051 need to ground pin 11 Tan/BK wire in PCM BLUE connector?

    Sure would like the TCC working...

    Thank you!!

    James

    P.S. Need to edit my sig... No more TPI...dropped an exhaust valve and lunched the block and head...
    My guess is the PCM is looking for +12VDC from the cruise control brake switch to some pin to activate lockup. The stock TBI PCMs use the same input to lock the converter. Without 12 volts supplied to the brake switch pin of the PCM the converter will not lock. Took me some time when I retrofitted to my first PCM to find out why the lockup would not command. Worked fine on the 7747, went to the 7427 and no lockup. My guess is you lost 12vdc to the cruise and need it for the PCM.

  3. #3
    Fuel Injected! bybyc5's Avatar
    Join Date
    Feb 2013
    Location
    NE, Tennessee
    Age
    62
    Posts
    73
    Thank you Fast355,

    I will research this out...sounds good as I see on my 8625 pin A-10 wt wire a signal either to or from the cruise control.
    Don't see a similar pin in the 8051 pin outs. Hmmmm...gives me a direction to go. I'll search out the LT1 cruise control module function/pin outs and see what I can find.

    Do you know if you can piggy back two VSS signals from the one VSS in the transmission?
    My stock Cruise Control module and Rear Wheel ABS module needs a signal from the stock speed signal buffer module, and I had to remove the stock VSS connector (which fed this buffer module) from the trans to hook up the LT1 harness for VSS input.

    Still curious about the EBTCM TP pin 12 in the RED connector does....My guess is something with traction control, which I don't have and not all F-bodies had it either. My formula does not, but a guy I know that used to have a Z28 did have it, albeit not for long....

    Worse case scenario is I set up either the canister purge circuit or the egr circuit to ground the TCC pin. Really would rather it be correct though.
    Either that or I will have to piggy back the two pcm's...not desirable.

    Thank you!

    James
    04 Lightning Pullies n Tune CAI
    96 Formula WS-6 m6 383 LE3-Heads/GM847/N2O/ Ford 9" 4:33/Sus Work/Stickies/TunerProRT
    93 K1500 383 LT1 with Low RPM 4x4 torque cam

  4. #4
    Fuel Injected!
    Join Date
    Feb 2013
    Location
    Euless, TX
    Posts
    1,460
    Quote Originally Posted by bybyc5 View Post
    Thank you Fast355,

    I will research this out...sounds good as I see on my 8625 pin A-10 wt wire a signal either to or from the cruise control.
    Don't see a similar pin in the 8051 pin outs. Hmmmm...gives me a direction to go. I'll search out the LT1 cruise control module function/pin outs and see what I can find.

    Do you know if you can piggy back two VSS signals from the one VSS in the transmission?
    My stock Cruise Control module and Rear Wheel ABS module needs a signal from the stock speed signal buffer module, and I had to remove the stock VSS connector (which fed this buffer module) from the trans to hook up the LT1 harness for VSS input.

    Still curious about the EBTCM TP pin 12 in the RED connector does....My guess is something with traction control, which I don't have and not all F-bodies had it either. My formula does not, but a guy I know that used to have a Z28 did have it, albeit not for long....

    Worse case scenario is I set up either the canister purge circuit or the egr circuit to ground the TCC pin. Really would rather it be correct though.
    Either that or I will have to piggy back the two pcm's...not desirable.

    Thank you!

    James
    You should be able to bypass the VSSB aka dRAC and use the speed signal output from the LT1 PCM to feed your RWABS and the Cruise. The LT1 cars and Vortec trucks use the PCM the same way that older vehicles used the VSSB or DRAC. If not you can piggyback the signals but the polarities have to match. If you piggy back and suddenly lose a speed signal, swap the wires at one of the modules. When I was running OD Maf with a 4L60E I had to do the same thing with the TBI PCM. The white wire from the PCM to the Cruise just tells the PCM the cruise is enabled which turns on the cruise control shift tables.

  5. #5
    Fuel Injected!
    Join Date
    Sep 2013
    Location
    Tulsa, Ok
    Age
    41
    Posts
    448
    This is from 97 LT1 Camaro cruise control.
    Attached Images Attached Images
    If it don't fit force it, if it don't force fit f&%@ it!

  6. #6
    Fuel Injected!
    Join Date
    Sep 2013
    Location
    Tulsa, Ok
    Age
    41
    Posts
    448
    This is from a 95 1500.
    Attached Images Attached Images
    If it don't fit force it, if it don't force fit f&%@ it!

  7. #7
    Fuel Injected! bybyc5's Avatar
    Join Date
    Feb 2013
    Location
    NE, Tennessee
    Age
    62
    Posts
    73
    Quote Originally Posted by Fast355 View Post
    You should be able to bypass the VSSB aka dRAC and use the speed signal output from the LT1 PCM to feed your RWABS and the Cruise. The LT1 cars and Vortec trucks use the PCM the same way that older vehicles used the VSSB or DRAC. If not you can piggyback the signals but the polarities have to match. If you piggy back and suddenly lose a speed signal, swap the wires at one of the modules. When I was running OD Maf with a 4L60E I had to do the same thing with the TBI PCM. The white wire from the PCM to the Cruise just tells the PCM the cruise is enabled which turns on the cruise control shift tables.
    That's good to know.
    Thank you!

    Now have some circuit checking to do...

    Thanks again,

    James
    04 Lightning Pullies n Tune CAI
    96 Formula WS-6 m6 383 LE3-Heads/GM847/N2O/ Ford 9" 4:33/Sus Work/Stickies/TunerProRT
    93 K1500 383 LT1 with Low RPM 4x4 torque cam

  8. #8
    Fuel Injected! bybyc5's Avatar
    Join Date
    Feb 2013
    Location
    NE, Tennessee
    Age
    62
    Posts
    73
    Quote Originally Posted by buddrow View Post
    This is from a 95 1500.
    Thank you for the diagram's. This will help me identify the circuits I need to deal with!

    I hope I don't let the smoke out of one of these modules.

    Thank you,

    James
    04 Lightning Pullies n Tune CAI
    96 Formula WS-6 m6 383 LE3-Heads/GM847/N2O/ Ford 9" 4:33/Sus Work/Stickies/TunerProRT
    93 K1500 383 LT1 with Low RPM 4x4 torque cam

  9. #9
    Fuel Injected!
    Join Date
    Sep 2013
    Location
    Tulsa, Ok
    Age
    41
    Posts
    448
    Hope it helps. gimme a few and I'll see about posting the actual circuit requirements. This is transplanting into the 95ish 1500 correct?
    If it don't fit force it, if it don't force fit f&%@ it!

  10. #10
    Fuel Injected!
    Join Date
    Sep 2013
    Location
    Tulsa, Ok
    Age
    41
    Posts
    448
    See if this gets you where you need to be as far as the multi-function and brake switch operation affects the cruise module on the 95.
    Attached Images Attached Images
    If it don't fit force it, if it don't force fit f&%@ it!

  11. #11
    Fuel Injected!
    Join Date
    Sep 2013
    Location
    Tulsa, Ok
    Age
    41
    Posts
    448
    Also, if you have the CHMSL, check the bulb, if the bulb is blown it can affect cruise operation.
    If it don't fit force it, if it don't force fit f&%@ it!

  12. #12
    Fuel Injected! bybyc5's Avatar
    Join Date
    Feb 2013
    Location
    NE, Tennessee
    Age
    62
    Posts
    73
    Quote Originally Posted by buddrow View Post
    Hope it helps. gimme a few and I'll see about posting the actual circuit requirements. This is transplanting into the 95ish 1500 correct?
    Thank you for the added info.
    It's a 93 K1500 and yes it's an LT1 transplant. 16168625 is the old PCM, and 16188051 is the LT1 PCM, using 1994 LT1 bins because my 1993 4L60E is NOT a pulse width modulated TCC lock up, it's either on or off...And right now mine is always off....

    I do see a possibility for me to try. Thanks to the schematics you provided and the info from Fast355. Looks like the 16168625 PCM uses a boo ( brake on/off ) signal to disengage the TCC, and the 16188051 looks FOR a Key + signal on the TCC pin to signal the PCM for lock up...unless I looked at it wrong...having winows 10 issues today and am cross eyed from tech their support...

    I really appreciate all the input guys.. next round of carbonated beverages are on me !!
    04 Lightning Pullies n Tune CAI
    96 Formula WS-6 m6 383 LE3-Heads/GM847/N2O/ Ford 9" 4:33/Sus Work/Stickies/TunerProRT
    93 K1500 383 LT1 with Low RPM 4x4 torque cam

  13. #13
    Fuel Injected!
    Join Date
    Sep 2013
    Location
    Tulsa, Ok
    Age
    41
    Posts
    448
    Here is the schematic for the 93. Operation should be the same as should the wiring, but in 95 they did change some things so I would use the 93 diagram to be positive. My apologies if the comments are blurry, I have no control over that part since the pic is from GM factory manual and it's not a high resolution pic.

    Bud
    Attached Images Attached Images
    If it don't fit force it, if it don't force fit f&%@ it!

  14. #14
    Fuel Injected! bybyc5's Avatar
    Join Date
    Feb 2013
    Location
    NE, Tennessee
    Age
    62
    Posts
    73

    Problem Solved !!

    Got to tip my hat and say THANK YOU!!

    Got it all working as designed. TCC locking up correctly, and all other modules receiving VSS inputs.
    I piggy backed the VSS at the Trans Tail shaft, of coarse got it backwards first try...but swapping the polarity worked!

    And looking at the schematics you gave me ( Thank you ) I wired a normally closed relay to keep Key+ power applied to the BOO circuit, opening the circuit when the brake pedal is applied...works perfect!

    Who'd a thunk stepping on the brake pedal interrupts power to the PCM...

    I appreciate all the effort you guys gave me!!

    Thank You,

    James
    04 Lightning Pullies n Tune CAI
    96 Formula WS-6 m6 383 LE3-Heads/GM847/N2O/ Ford 9" 4:33/Sus Work/Stickies/TunerProRT
    93 K1500 383 LT1 with Low RPM 4x4 torque cam

  15. #15
    Fuel Injected!
    Join Date
    Sep 2013
    Location
    Tulsa, Ok
    Age
    41
    Posts
    448
    Good deal! Glad we could be of assistance.

    Bud
    If it don't fit force it, if it don't force fit f&%@ it!

Similar Threads

  1. 4L80E with 16168625 ECU, is this normal?
    By wanderingturtle in forum GM EFI Systems
    Replies: 27
    Last Post: 05-12-2017, 11:09 AM
  2. Shift points/lock up
    By old truck guy in forum GM EFI Systems
    Replies: 5
    Last Post: 08-27-2015, 01:41 PM
  3. no lock option.
    By doctortuned in forum TunerCat OBDII
    Replies: 17
    Last Post: 08-13-2014, 11:32 AM
  4. TCC lock up in 3rd
    By damanx in forum GM EFI Systems
    Replies: 8
    Last Post: 12-01-2013, 01:10 PM
  5. 16168625 PCM Information $E6
    By EagleMark in forum GM ECM - Bins - TunerPro Definition Files - Wiring Diagrams - Tuner Info!
    Replies: 6
    Last Post: 03-12-2012, 06:51 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •