Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Results 1 to 4 of 4

Thread: 1990 Corvette Starts then dies

  1. #1
    Fuel Injected!
    Join Date
    Nov 2016
    Posts
    66

    1990 Corvette Starts then dies

    This is a newly rebuilt engine. I'm using and edelbrock pro-flo intake manifold and style LS1 throttle body, TPS and MAP sensors, small cap distributor with remote coil, 32lb/hr injectors, bigger cam and brodix IK180 heads. So far I have found that my TPS sensor voltage is only 0.89 volts at the TPS and at the pin out for TPS at the ECM. That wire should be 5.0V. I really do no understand why straight out of the ECM is only 0.89V. I have tried two ECMs and both gave the exact same voltage. Can someone tell me where the power comes from before it gets to the TPS pin out? I think there is probably a short somewhere. Will a broken knock sensor prevent engine from running? the plastic piece the clip goes onto in the center is broken and loose just basically floating in the center. There is a black two pin plug with green rubber seal at the drivers side front of the engine. The wire emerges from the fuel injector harness. I need to know what that originally went to.

  2. #2
    Fuel Injected! uncabob's Avatar
    Join Date
    Jan 2016
    Age
    81
    Posts
    121
    "Two pin plug". Oil pressure sensor? On my engine it is just below the distributor. ('84 350). Keeps the fuel pump running after oil pressure gets up.If your engine dies soon after starting, it sounds like your fuel pump relay circuit is giving you a prime but oil pressure is not being recognized by the ECM. Try watching fuel pressure key-on-engine-off. If the fuel pump stops after a few seconds the ECM has turned off the relay and the pressure sensor hasn't taken over the fuel pump circuit. I don't know your ECM, but you can check the diagrams to see where the sensor connects to it and check for continuity to it. One side to ECM, the other to fuel pump +12. If this is your problem, a paper clip between the pins of the plug will keep your engine running. Would recommend using pressure sensor as final solution though.
    Last edited by uncabob; 11-21-2016 at 07:41 AM. Reason: Change ground to +12 on fuel pumpfuel pump
    Don't force it, get a bigger hammer!

  3. #3
    Fuel Injected! uncabob's Avatar
    Join Date
    Jan 2016
    Age
    81
    Posts
    121

    C4 tech/performance

    Check here for info on oil pressure sending unit on 1990 C4. corvetteforum.com/forums/c4-tech-performance/419829-oil-pressure-sending-unit
    Last edited by uncabob; 11-20-2016 at 09:03 AM.
    Don't force it, get a bigger hammer!

  4. #4
    Fuel Injected!
    Join Date
    Nov 2016
    Posts
    66
    Quote Originally Posted by uncabob View Post
    "Two pin plug". Oil pressure sensor? On my engine it is just below the distributor. ('84 350). Keeps the fuel pump running after oil pressure gets up.If your engine dies soon after starting, it sounds like your fuel pump relay circuit is giving you a prime but oil pressure is not being recognized by the ECM. Try watching fuel pressure key-on-engine-off. If the fuel pump stops after a few seconds the ECM has turned off the relay and the pressure sensor hasn't taken over the fuel pump circuit. I don't know your ECM, but you can check the diagrams to see where the sensor connects to it and check for continuity to it. One side to ECM, the other to ground. If this is your problem, a paper clip between the pins of the plug will keep your engine running. Would recommend using pressure sensor as final solution though.
    Thanks, I fixed it. It was mixed up wires for the MAP sensor.

Similar Threads

  1. 1990 highly modified 434 corvette tune issue
    By bjankuski in forum GM EFI Systems
    Replies: 1
    Last Post: 07-15-2015, 10:40 PM
  2. 1990 Corvette (Y Body) ADX File?
    By C4ProjectCar in forum GM EFI Systems
    Replies: 6
    Last Post: 12-08-2014, 11:30 AM
  3. 305 TPI dies when put in gear
    By greggbruceauto in forum GM EFI Systems
    Replies: 3
    Last Post: 12-17-2013, 01:41 PM
  4. Starts then stalls ......
    By Nasty-Z in forum GM EFI Systems
    Replies: 4
    Last Post: 04-06-2013, 08:18 AM
  5. Help! 90 Chevy Blazer starts runs dies?
    By ChrisBama in forum GM EFI Systems
    Replies: 3
    Last Post: 03-29-2013, 09:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •