Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Results 1 to 4 of 4

Thread: 440 Mopar TBI Swap, Questions

  1. #1
    Carb and Points!
    Join Date
    Mar 2016
    Age
    26
    Posts
    5

    440 Mopar TBI Swap, Questions

    Hey guys, longtime lurker and information leech here. I am installing a DIY TBI setup on a 1973 440 that's slightly warmed up and is currently living in a Jeep Wagoneer. I am using an early 454 TBI unit with the flat TPS connector and a '7427 PCM and harness that I got from the JY out of a 1994 G20 conversion van.

    Here is where my confusion lies.

    The BCC on the outside of the computer housing says BDSD. When I look that BDSD BCC up, I can only find it here: http://www.scotthansen.net/BCCLookup.pdf

    BCC Year Release Date Eprom ECM Prom ID Scan ID Platform Engine Displacement Trans Trans Type
    BDSD 1994 33939 16188493 16168625 8494 8465 G1 LB4 4.3 M30 AUTO

    I am almost 99.9% positive the van in the JY was a V8, not a 4.3, but it has been a while. The actual memcal inside of the computer doesn't show a BCC on it, just numbers. Those numbers are: 4090 1617 4891.

    The ECM is a 7427 but I noticed something was amiss when none of the 7427 wiring diagrams were matching up properly. For example, F9 for me is an orange/black wire, which seems to match the $OE wiring diagrams. That makes even less sense considering the computer case BCC says it's for a 4.3...which wouldn't have had a 4L80...

    Basically, I'm just looking for some detective work help in trying to figure out exactly what I'm working with. From my reading the 7427 can run either $OD or $OE, and since my harness seems to match the $OE diagrams and I'm going to use a 7.4L bin to start my tuning, is it as simple as burning the $OE info to a chip and going from there?

  2. #2
    Fuel Injected!
    Join Date
    Feb 2013
    Location
    Euless, TX
    Posts
    1,426
    Quote Originally Posted by WT91 View Post
    Hey guys, longtime lurker and information leech here. I am installing a DIY TBI setup on a 1973 440 that's slightly warmed up and is currently living in a Jeep Wagoneer. I am using an early 454 TBI unit with the flat TPS connector and a '7427 PCM and harness that I got from the JY out of a 1994 G20 conversion van.

    Here is where my confusion lies.

    The BCC on the outside of the computer housing says BDSD. When I look that BDSD BCC up, I can only find it here: http://www.scotthansen.net/BCCLookup.pdf

    BCC Year Release Date Eprom ECM Prom ID Scan ID Platform Engine Displacement Trans Trans Type
    BDSD 1994 33939 16188493 16168625 8494 8465 G1 LB4 4.3 M30 AUTO

    I am almost 99.9% positive the van in the JY was a V8, not a 4.3, but it has been a while. The actual memcal inside of the computer doesn't show a BCC on it, just numbers. Those numbers are: 4090 1617 4891.

    The ECM is a 7427 but I noticed something was amiss when none of the 7427 wiring diagrams were matching up properly. For example, F9 for me is an orange/black wire, which seems to match the $OE wiring diagrams. That makes even less sense considering the computer case BCC says it's for a 4.3...which wouldn't have had a 4L80...

    Basically, I'm just looking for some detective work help in trying to figure out exactly what I'm working with. From my reading the 7427 can run either $OD or $OE, and since my harness seems to match the $OE diagrams and I'm going to use a 7.4L bin to start my tuning, is it as simple as burning the $OE info to a chip and going from there?
    Actually ALOT of G-vans and Express/Savana Vans had 4.3/4L80E drivelines. Even the newer vans used the 4L80E behind the little 4.8.

  3. #3
    Carb and Points!
    Join Date
    Mar 2016
    Age
    26
    Posts
    5
    Huh, I never would've expected that. Learn something new every day. So I would guess that even though its a 4.3L, would it be a $OE PCM? I'm just not sure where to start with the programming/tweaking aspect. I'm running a 727 trans so obviously no trans controls, no EGR, no evap system, etc. So lots of disabling I have to do with whatever .bin I try to run, I was going to try a $OE 7.4L 5 speed program since that wouldn't have anything for the transmission.

  4. #4
    Carb and Points!
    Join Date
    Mar 2016
    Age
    26
    Posts
    5
    So I have made a ton of progress and now have another question/concern. I have my setup "Running" on the truck. It seems to do well, but every so often the otherwise very nice idle just drops and the engine either stalls or struggles to recover. I have no idea what could be causing this. Fuel pressure is good, ICM is brand new, coil is brand new, timing is set at 4* advanced as per the 7.4L BMHK .bin I am using. I have corrected the .bin for the 74 lb/hr injectors I am using. I had some issues with a clogged fuel filter and then running out of gas but I have confirmed now that both the tank has fuel, the fuel pickup is sucking said fuel, and the filter is clean and filling with said fuel. I do see in my datalogs that there are some very strange spark advance numbers. Like 5000 degrees advanced at 2000rpm 45 map. Or 11000 advanced at 6800 RPM, which I have never revved the engine up to. I suspected the distributor, so I replaced everything in it. New magnetic pickup, new rotor, new cap. What could cause this? I am attaching some data logs...thanks...
    Last edited by WT91; 06-03-2016 at 03:49 PM.

Similar Threads

  1. Vortec Head swap on my '92 TBI 350. Tuning questions.
    By jdyates in forum GM EFI Systems
    Replies: 73
    Last Post: 09-22-2016, 05:50 AM
  2. tbi 350 to 5.7 vortec swap: stupid questions
    By dusterbd13 in forum GM EFI Systems
    Replies: 4
    Last Post: 08-24-2014, 08:57 PM
  3. 94 HD 30 454 swap into 95 V6 P30 Van questions
    By bobx in forum GM EFI Systems
    Replies: 4
    Last Post: 07-04-2014, 01:03 PM
  4. Finished my 747 to 427 pin swap, got a few questions
    By CDeeZ in forum GM EFI Systems
    Replies: 4
    Last Post: 07-05-2012, 02:03 PM
  5. TBI to MPFI swap questions
    By JeepsAndGuns in forum GM EFI Systems
    Replies: 6
    Last Post: 03-13-2012, 05:02 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •