Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Results 1 to 4 of 4

Thread: 1990 Jeep Wrangler w/ Howell GM TBI & HEI, cut off idling now cranks, but won't start

  1. #1
    Carb and Points!
    Join Date
    Apr 2016

    1990 Jeep Wrangler w/ Howell GM TBI & HEI, cut off idling now cranks, but won't start

    Hey everyone, have a problem with my jeep and have been trying to figure it out for the past couple of weeks with no luck. It's a 1990 Jeep Wrangler 4.2L straight 6 with a Howell GM TBI kit and a HEI both of which the previous-previous owner installed. When I first got it it wouldn't start just cranked, after reading many forums I tried a new ECU/ECM (7747) and it started right up. However, I didn't know the Howell ECU had chips in it and the guy at the parts store never said anything when i handed him the Howell ECU as a core he just handed me the reman stock 7747 ECU and that's what I've been running with no chips. Once I found out I called the parts store, but was too late. Tried to get them from Howell, but they said I needed the original purchasers name, but unfortunately I couldn't get that info. I then replaced the intake/exhaust manifold gasket and valve cover gasket and it was running better, but still could improve. Fast forward a year later to now and it had been sitting for 2 weeks, but started right up, drove for 25 min and then the next day I started it up and after 2 minutes it just randomly cut off while idling and now just cranks all day, but won't start. To be honest Im a newb when it comes to mechanics, but have done things like my complete brakes front/rear, rotors on front drums in rear, most gaskets, and more.

    What I've done so far to figure this out was new battery and cleaned cables, cleaned most grounds (that I could see), checked fuses, and injectors don't spray when cranking, I can hear the fuel pump prime, it starts strong for a second with starter fluid, and tested spark using a screwdriver on one of the plugs and it seemed a little weak, but still ok.

    I checked fuel pressure, but I want to recheck it because I don't have a schreder (sp?) valve so I had to use this adapter t with a valve and I'm not sure if I had it hooked up good because I only had a ~3.5 in piece of rubber hose to use because I didn't want to cut my fuel line.

    Fuel pressure results- fuel pump primed and gauge went to 10 psi, but immediately dropped to 0 once the pump stopped priming. Also stayed at 0 when trying to crank. Will retest though once I get some proper fuel line from parts store.

    Hooked fuel pump directly up to battery and it was steady priming, but next test will be to see if it holds pressure while priming when I retest pressure.

    Now for the injectors...I removed the connectors on top of one of the injectors and put a noid light in the holes, had my friend crank the engine and nothing happened not even a dim flicker and this was the case for both of the injectors so I guess they aren't being told to fire? I just bought a multimeter, but not too sure how to use it.

    So conclusion- injectors aren't firing and fuel pressure drops to 0 after pump primes (will double check that tmrw after work when I get proper rubber fuel line)

    Also wanted to mention that pretty much since I got the jeep it's been really weird when it comes to starting. For example, I would drive to the gym and about an hour later hop in my jeep and it just would not start just crank and crank. Eventually it would start up after about 20 minutes of cycling the key on and off 15 times to prime the fuel pump over and over and sometimes I would unhook the battery to try and reset the computer as well. That started to get worse and worse as time went on to the point where I had to get it towed back home twice and then out of nowhere I'd go try to start it a couple hours later and it would crank right up after going through my start up protocol of cycling the key on and off priming the fuel pump. And now I'm at this point where it just cut off while idling, which it has never done, and it hasn't started up since the beginning of April when this happened...

    Also wanted to note that I used to be able to cycle the key on and off within 2-3 seconds and the fuel pump would prime every time. Now the fuel pump makes me wait about 7-8 seconds with the key off before I can turn it on to prime the fuel pump again. If I try to cycle the key sooner than that the fuel pump will not prime.

    So tmrw after work I plan on rechecking the fuel pressure and also checking it with the fuel pump hooked directly to the battery, but the injectors not firing is what I'm wondering about. On Howell GM TBI kits what causes the injectors to fire? Could the ECU fail while a vehicle is idling? Like I said it had a blown ECU when I got it (previous owner said he was jumping battery and saw smoke)(but not sure if that fried the computer or something else). By the way the previous owner didn't install the Howell kit or HEI, it was the guy before him. Could a bad alternator blow an ECU? Just curious because I think the only thing the PO had done to it was a re manufactured alternator put on.

    Sorry for the very long post, I wanted to include everything I could think of. Any help would seriously be much appreciated I'm lost at this point, thank you.
    Last edited by Canebeast; 04-25-2016 at 08:04 PM.

  2. #2
    Join Date
    May 2011
    Lakes Region, NH
    Welcome to the forum!

    If you've never installed any chips then you should stop all other diagnosis and get some chips installed. Make sure the part responsible for controlling fuel (and spark?) can do the job you want it to do. I'm not even sure how the ecm has ever managed to make the engine run without them. You need a chip installed in both of the circled locations.

  3. #3
    Carb and Points!
    Join Date
    Apr 2016
    Hey, sorry for the late response, I feel like an idiot, but yes I have the correct Howell chip and I limp home chip installed so I'm good on that. I remember I had to go back to my car to grab my wallet and I had both ECMs on the table so he must of put in the chips in under 2 minutes lol.

    I tried a 1227747 from a working vehicle (put my chips into it) and still nothing, so my ECM must still be good and not blown. I'm just at a loss for what it could just randomly cut off while idling, now just doesn't start.

    -Battery is good
    -Connections/grounds seem to be good
    -Fuses seem good
    -Fuel pump primes and pressure is 10 psi and drops to 0 after pump primes (apparently that's normal)
    -Spark is good
    -It starts up and then dies with starter fluid
    -Voltage to distr checked out good in run position and while cranking
    -New ECM did nothing
    -Tach filter is getting the right voltage and resistance seemed good from tach filter to distr
    -Injectors did not pass noid light test

    Maybe my injectors are fried? Can injectors just give out like that while a vehicle is idling? I search the internet every night for hours upon hours trying to find anyone with a similar problem, but haven't come up with anything. I read somewhere about a CPS, but I don't think my jeep has one? I looked over the Howell kit instructions and never saw anything about a CPS and my jeep manual for the 4.2 doesn't mention one either so I guess that rules that out. Also read the ignition control module and the coil pack. I know I tested the distr to make sure it's getting power while on and while cranking, but does that rule out the coil pack being bad? Thanks for your reply, any and all help is much appreciated, I'm lost here

  4. #4
    Fuel Injected!
    Join Date
    Sep 2012
    Fort Smith, Ar
    ICM can cause those symptoms, (have fire but no fuel pulse) maybe something to check....

Similar Threads

  1. 1992 Jeep Wrangler with 350TPI/700R4 VSS Options
    By misterpat in forum GM EFI Systems
    Replies: 92
    Last Post: 03-22-2015, 08:10 AM
  2. GM TBI No Start Jeep 4.0 I6
    By Baskinator in forum GM EFI Systems
    Replies: 8
    Last Post: 02-10-2015, 03:14 PM
  3. engine not idling correctly after tbi conversion
    By Tyree in forum GM EFI Systems
    Replies: 44
    Last Post: 01-28-2014, 07:36 PM
  4. Replies: 78
    Last Post: 01-10-2014, 04:38 PM
  5. GM '7427 PCM / Jeep Wrangler question
    By Nasty-Z in forum GM EFI Systems
    Replies: 2
    Last Post: 05-25-2012, 08:32 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts