Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Results 1 to 4 of 4

Thread: running 24x gen 3 engine on the E38 ecm

  1. #1
    Fuel Injected!
    Join Date
    Apr 2013
    Location
    West Plains, Missouri
    Posts
    24

    running 24x gen 3 engine on the E38 ecm

    Working with a 2007 5.3l truck application, In Tuner CATS OBD2 Tuner there are a few settings for ''crank decoder method'' and "camshaft pulse per revolution" Default value is 8 for decoder, and 4 for pulses per rev.

    I got the following info from John at TC about the different settings for crank decoder method, as follows.

    0 = 24X Angle
    1 = 24X Time Crank A
    2 = 24X Time Crank B
    3 = 6X Threshold
    4 = 6X Percentage
    5 = 5X Threshold
    6 = 5X Percentage
    7 = 58X Threshold
    8 = 58X Percentage (stock setting)
    255 = Disabled

    I have a gen 3 24x/1x block, crank, timing set, and camshaft setup with a drill. I've wired the crank and cam sensors up to an E38 on my bench harness and using Tech 2 to monitor crank rpm and pulse activity. I've tried setting 0,1,2 and so far I am not able to see any crank activity, however, the ECM is reading the 1x cam sensor. I have tested the wave form on the sensor outputs and verified good 5 volt square wave signals from cam & crank sensors. anyone else messed with this or have any other input??

    thanks

    Brendan.

  2. #2
    Fuel Injected!
    Join Date
    Jun 2014
    Posts
    148
    Tried something similar quite awhile ago. Could get the 58x turned "off", but could not get the 24x turned "on".

    Left me to conclude that there must be additional unknown parameters necessary to make the 24x signal functional.

  3. #3
    Carb and Points!
    Join Date
    May 2014
    Posts
    9
    The 24x data is not compiled into the BIN file. So even if you turn it "on" The ECU doesn't know what to do with the data. The channel just goes dead.

  4. #4
    Don't bother.
    Buy a Lingenfelter 58X to 24X converter and be happy. It works very good and it's plug&play

Similar Threads

  1. first chip engine still not running maybe bad IAC please look at log
    By Greased-lightning in forum TunerPro Tuning Talk
    Replies: 2
    Last Post: 05-10-2015, 07:15 PM
  2. Replies: 10
    Last Post: 04-21-2015, 08:28 PM
  3. Replies: 52
    Last Post: 11-07-2014, 04:24 PM
  4. Engine temp vs Engine efficiency
    By sciroc in forum GM EFI Systems
    Replies: 2
    Last Post: 05-16-2014, 04:51 PM
  5. TPI Engine Running
    By dave w in forum GM EFI Systems
    Replies: 2
    Last Post: 06-29-2011, 07:58 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •