Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Page 22 of 23 FirstFirst ... 1217181920212223 LastLast
Results 316 to 330 of 343

Thread: Anyone worked with the 16196397 yet?

  1. #316
    Carb and Points!
    Join Date
    May 2017
    Location
    Perth, Western Australia
    Age
    32
    Posts
    6
    Your adx is still broken, im not sure what is wrong with it. you also seem to be having some data collisions occasionally.
    However the information is still in there; Attached is a graph from the E-side log
    Attached Images Attached Images
    Last edited by charlay86; 06-21-2017 at 05:28 PM.

  2. #317
    Fuel Injected!
    Join Date
    Jun 2015
    Age
    30
    Posts
    340
    Ok, so I guess we just need to figure out why it no longer runs...

    Given that the tables are correct, (it runs fine with a 1 bar sensor installed, or if I tell the PCM that it's a 1 bar and cut the injector size in half) what else could be causing the lack of at least *some* life? I guess tomorrow I will start cutting injector size down, and working it back up while correcting the table (move injector size to something that works, then change main VE to match in % change, then move injector size back, in small % increments)
    Last edited by Xnke; 06-21-2017 at 09:08 PM.

  3. #318
    Fuel Injected!
    Join Date
    Jun 2015
    Age
    30
    Posts
    340
    Charles has pointed out in some PM's that I have been multiplying MAP by zero...so gotta fix that now. He's right-that certainly won't be helping things.

    Hoping for more luck tomorrow.

  4. #319
    Fuel Injected!
    Join Date
    Jun 2015
    Age
    30
    Posts
    340
    IT RUNS!

    Yes, No false alarms, no "it runs kinda", it RUNS. Took it around the block, got a nice long log. Here's the current XDF, ADX, XDL, and BIN file!

    I'm told there are still some minor things that need to be fixed, and I need to finish up the Wideband data logging, and I need to learn to use Tunerpro more effectively, but the *really hard* part of this build is done and down!

    I am so relieved that this part is finished and working. Now I can start on the really fun part of the project-making it into a nice daily again.
    Attached Files Attached Files

  5. #320
    Carb and Points!
    Join Date
    May 2017
    Location
    Perth, Western Australia
    Age
    32
    Posts
    6
    Glad to hear it's working!
    I'll just make a list of outstanding items here:
    - Wideband lambda support
    - Boost control / inhibit
    - Reinstate default MAP operation (in case of MAP sensor failure. Ideally with the option of inhibiting boost, but otherwise could be tuned as general alpha-N mode)
    - Baro update fix (requires boost control so we can update under highway mode)

  6. #321
    Carb and Points!
    Join Date
    May 2017
    Location
    Perth, Western Australia
    Age
    32
    Posts
    6
    Wideband is done, pending testing.
    It's a tight squeeze dealing with the T-side!

  7. #322
    Fuel Injected!
    Join Date
    Jun 2015
    Age
    30
    Posts
    340
    Also just noticed that my spark table is back to being 0-4800RPM, wheras before, we had it at 0-6400RPM. It's a single byte fix, I just gotta remember how to do it. (change 61 to 64, and that's all that needed to be done)

  8. #323
    Fuel Injected!
    Join Date
    Jun 2015
    Age
    30
    Posts
    340
    Drove this today. Got a lot of work left to do, but it made it the mile trip to the gas station and back. Now, little detail work has to be done to make it drivable back home!

    Once home, things like A/C, radio, air filter tube, cold air intake plumbing, etc can all be done much easier and faster than at the combustion lab.

  9. #324
    Fuel Injected!
    Join Date
    Jun 2015
    Age
    30
    Posts
    340
    Been driving this a decent bit this week-will be going on the first long trip tomorrow, 2.5 hour drive each direction.

    If it manages that, then it'll be considered "road ready", and I'll be more focused on tuning for power than I am monitoring vital signs!

  10. #325
    Fuel Injected!
    Join Date
    Jun 2015
    Age
    30
    Posts
    340
    So having some idle problems and A/C issues-some weird stuff happening.

    Anyway-here's the current state of the ADX/XDF/BIN, and a log of the A/C problem.

    Basically the A/C can be requested, it's enabled, then the enable goes away, then the AC request goes away. Have no idea what it could be at this point.
    Attached Files Attached Files

  11. #326
    Fuel Injected!
    Join Date
    Jun 2015
    Age
    30
    Posts
    340
    A/C problem solved, if not using the Camaro A/C evaporator temperature sensor, check "A/C Contingency" and set the option bits as per an L or N body car.

    Currently running 5.5psi boost, using the stock L67 drive ratio-so the 3.4L breathes a good bit better! (same boost as a stock L67, but 0.4L less displacement!)

    I've developed an exhaust leak on the right-side collector, so it's skewing the BLM's and thus the fueling on the right side when in closed loop. In open loop, the truck runs absolutely fine-but closed loop it has a rich stumble and has lost considerable fuel economy-almost 2.5MPG. Once repaired I should return to the 30MPG that it was getting early on, before the gasket burned out.

  12. #327
    Super Moderator
    Join Date
    Mar 2011
    Location
    Camden, MI
    Age
    29
    Posts
    3,026
    sorry I had to drop out of the project, but I'm happy to see the two of you managed to managed to organize the chaos I threw out.
    1995 Chevrolet Monte Carlo LS 3100 + 4T60E


  13. #328
    Fuel Injected!
    Join Date
    Jun 2015
    Age
    30
    Posts
    340
    No problem man. There are still a few details that I need to work out but the code, as is, works now. Boost reliability is not really well tested out-but I am hoping to be posting the modded XDF and ADX here *very* soon. I haven't quite got the ADX errors to completely stop yet, ocassionally I'll start up the truck and it goes back to how it was months ago-but a solid 85% of the time it's a clean datastream now.

  14. #329
    Fuel Injected!
    Join Date
    Jun 2015
    Age
    30
    Posts
    340
    Got the ADX errors to completely stop, got the thing boosted and blew up the trans.

    2nd gear, stripped all the teeth off under load. Goofing off, as you do.

    A/C doesn't work if over 50kpA manifold vacuum, AND over 35mph. Ignores all the hysteresis logic, and chatters like hell when it engages/disengages.

    Still haven't figured that bit out, but I'll get it worked out sooner or later.

  15. #330
    Fuel Injected!
    Join Date
    Jun 2015
    Age
    30
    Posts
    340
    Still hunting the A/C buzzkill...it's 90+ degrees on my 40 minute interstate drive home from work a lot of days here and I only have A/C if my MAP value is less than 50KpA. There's nothing in the current XDF that links A/C clutch disable/enable with MAP, and I'm hunting through the dissassembly and not finding much. Mostly on the T-Side, I can find this:

    RAM:0089 ; A/C BIT STATUS WORD
    RAM:0089 ; 0 0 = A/C CLUTCH ENABLED
    RAM:0089 ; 1 1 = A/C WOT LOGIC USING N/V TIME THRESHOLD
    RAM:0089 ; 2 1 = A/C PRESSURE REQUESTS FAN
    RAM:0089 ; 3 1 = A/C PRESSURE REQUESTS FAN # 2
    RAM:0089 ; 4 1 = A/C LOAD SWAP (A/C FORCED OFF)
    RAM:0089 ; 5 1 = A/C OLD (6.25 MS.) 3RD GEAR FLAG
    RAM:0089 ; 6 1 = A/C EVAP TEMPERATURE CLUTCH DISABLE (F-only?)
    RAM:0089 ; 7 1 = A/C CFIV FREON LOW CLUTCH DISABLE (F-only?)

    It seems that if I can figure out what byte 0089 bit 4, does, I might have a chance at fixing this. I suspect it's just another location that needs to pick up the new 2-bar map value, because if it's meant to force the A/C off at max load of 100kpA, and it did NOT get the new 2-bar map value, it would tend to force the A/C off at the 50kpA with the new MAP sensor. Problem is, I don't have the slightest idea of how or where to find it.

    I don't think it's bit 6 or 7, as bit 6 is disabled and bit 7 isn't being toggled (it's currently in the ADX as part of the datastream). Currently, the ADX is logging bit 0, bit 2, bit 3.

Similar Threads

  1. 16172693 16184164 16184737 16196397 PCM Information P66 V6
    By RobertISaar in forum GM ECM - Bins - TunerPro Definition Files - Wiring Diagrams - Tuner Info!
    Replies: 5
    Last Post: 04-18-2014, 07:49 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •