Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Results 1 to 12 of 12

Thread: Strange issue using red devil river and aldl droid

  1. #1
    Fuel Injected!
    Join Date
    Nov 2014
    Posts
    25

    Strange issue using red devil river and aldl droid

    Greetings,
    just got the red devil river connected to my gm ecm and am connecting to it with the aldldroid app. The monitoring is good, but the strangest thing happens when I connect to the red devil via blue tooth, the idle speed goes up to 1000 rpm.

    when I disconnect, it goes back down to 650ish.

    i have "desired idle speed" as a readout on aldldroid and it says 1000. However, when connecting to the ecm with a USB adapter to PC using winaldl, the idle speed is unaffected and "desired idle speed" reads 600.

    anyone seen anything like this? Even better, know how to solve it? Make it kind of tough to use the device to verify idle speed.

    system background:
    gm 5.7l in. Y boat. Put a long block in this summer and decided to go from carb to EFI. Bought a kit from affordable fuel injection. It came with a salvaged ECM 16144288. The ADX file is e $A0.adx with one mod to make the "coolant temp" names different.

    Any ideas will, of course, be greatly appreciated.

    Regards,
    david

  2. #2
    Super Moderator Six_Shooter's Avatar
    Join Date
    Feb 2011
    Posts
    2,828
    Sounds like "ALDL Diagnostic mode" is being enabled that will raise the idle RPM as a way of verifying that mode is indeed enabled. Usually to do this there is a 10K resistor that is is shorted across pins A and B of the ALDL connector though. Most cables have a physical switch or jumper to enable this.

    There might be something in the ADX that is causing this mode to be enabled as well. Maybe it's using a mode other than Mode 1 for ALDL communications?
    The man who says something is impossible, is usually interrupted by the man doing it.

  3. #3
    Fuel Injected!
    Join Date
    Sep 2012
    Location
    washington indiana
    Age
    62
    Posts
    806
    when you open your dash in tuner pro right click on one of the dash [rpn,iac count] or what ever and look at that bit map there is a adl mode it should tell you if that's coming on. what is the letters on the chip you have installed? I haven't seen a 288 on a 5.7 some 299's. heres a adx with a few more thing on it for a $ao.

  4. #4
    Fuel Injected!
    Join Date
    Nov 2014
    Posts
    25
    Thank you,
    that seems to be the case. Looks like the red devil river USB interface has the 10k resistor that puts the ECM on diagnostic mode.
    i am looking for the way to disable it.

  5. #5
    Fuel Injected!
    Join Date
    Nov 2014
    Posts
    25
    Thank you for the adx file.

    This ECM was sold to me as part of a retrofit kit from "affordable fuel injection". Guess having a salvaged ECM is what makes it " affordable".

    I have now had a few people tell me they have never seen my model ECM on a 5.7liter engine. What is the down side of this? Is there a better unit to use?

    This is in my boat. I replaced the carburetor with the fuel injection system. Up side of all that is the engine starts right up every time. However, I am having issues with the idle the idle speed drops low then the iac opens more nod revs the engine a bit. Sometimes it dies.

    If I can solve that issue, the boat will be ready for next season.

  6. #6
    Fuel Injected!
    Join Date
    Sep 2012
    Location
    washington indiana
    Age
    62
    Posts
    806
    a 1227747 should be a plug an play, 288 is what I have in my 4.3 v6 there is a lot better adx and adl files for the 747 unless some one has modified the 288 it is for a 6 cylender I ment xdf file.
    Last edited by ony; 11-19-2014 at 05:43 AM.

  7. #7
    Fuel Injected!
    Join Date
    Nov 2014
    Posts
    25
    I will look for a 747. In any case, you are correct about the unit being modified. The guys from "Affordable Fuel Injection" sent it as part of the package I purchased from them.

    I am am looking for a back unit anyway since it is in a single engine boat. If the ecm fails a few Miles out in the ocean...well, not fun.

  8. #8
    Fuel Injected! devind's Avatar
    Join Date
    Jan 2013
    Age
    49
    Posts
    134
    Not for sure with the blue tooth. But with a ALDL cable with the 10 k resistor all you have to do is pull the ground (A) out of the ALDL plug under the dash and it will still be able to transfer data to data log but with out the ground it wont be able to pull a any resistance causing it to adle up 1000rpm.

  9. #9
    Fuel Injected!
    Join Date
    Nov 2014
    Posts
    25
    One other question. Do you know of a comparison chart to detail the differences between the 288 and 747?

  10. #10
    Super Moderator Six_Shooter's Avatar
    Join Date
    Feb 2011
    Posts
    2,828
    Quote Originally Posted by devind View Post
    Not for sure with the blue tooth. But with a ALDL cable with the 10 k resistor all you have to do is pull the ground (A) out of the ALDL plug under the dash and it will still be able to transfer data to data log but with out the ground it wont be able to pull a any resistance causing it to adle up 1000rpm.
    This actually won't work, at least not reliably. The ground is needed for a voltage reference, so that the communications are referenced to the same ground potential. The voltage above this ground potential determines when there is and isn't a bit being transmitted, or more correctly what level of bit is being transmitted, a 0 or a 1.
    The man who says something is impossible, is usually interrupted by the man doing it.

  11. #11
    Fuel Injected!
    Join Date
    Nov 2014
    Posts
    25
    You are correct. The ground is needed. I got a note from the maker of the blue tooth interface. He said pin B is the control pin. I can try to see if pulling that pin will still give me data and not go in to diagnostic mode.

    If it works, I can remove the 10k resistor from inside the interface box and reinstall the wire.

  12. #12
    Fuel Injected!
    Join Date
    Nov 2014
    Posts
    25
    Thank you to all that replied. I modified the blue tooth box a bit and the idle is now unaffected. The "red devil river" and "aldl droid" combination is fabulous. Now I can fine tune the boat engine.
    David

Similar Threads

  1. Strange shifting after Speedometer calibration
    By Oysteinbno in forum GM EFI Systems
    Replies: 9
    Last Post: 08-10-2014, 04:52 PM
  2. help obd1 your my only hope have strange readings on tuner??
    By swat455 in forum TunerPro Tuning Talk
    Replies: 14
    Last Post: 04-03-2013, 10:56 PM
  3. Really strange idea of the day!!!
    By jim_in_dorris in forum GM EFI Systems
    Replies: 59
    Last Post: 03-03-2012, 07:21 PM
  4. '94 5.7 Strange EGR issue
    By gregs78cam in forum GM EFI Systems
    Replies: 9
    Last Post: 02-26-2012, 11:22 AM
  5. River City Rod Run Tonight!!!
    By EagleMark in forum Gear Heads
    Replies: 0
    Last Post: 07-15-2011, 12:34 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •