Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Page 1 of 2 12 LastLast
Results 1 to 15 of 25

Thread: 1995 SLP Firehawk

  1. #1
    Fuel Injected!
    Join Date
    Oct 2014
    Age
    34
    Posts
    44

    1995 SLP Firehawk

    This car runs rich seems way underpowered I use Datamaster LTFT and way red. I clead MAF full tune, cap rotor, no cat, new 02. I added 1 to MAF tables locked BLM. Please help

  2. #2
    Fuel Injected! steveo's Avatar
    Join Date
    Aug 2013
    Posts
    2,378
    way red meaning lower than 128? red in datamaster means lower than 128. that means it's running RICH and it's removing fuel

    you added 1 to the entire MAF table. that reads MORE airflow and dumps MORE fuel.

    then you subtracted one from the injector constant. that reads LESS injector flow, so dumps MORE fuel.

    you're tuning backwards!!

    try running a stock maf table and injector constant, do another log with datamaster, and post it so we can have a look

  3. #3
    Fuel Injected!
    Join Date
    Oct 2014
    Age
    34
    Posts
    44
    thanks yea rich but idle i put a wideband on is 18.0:1 just bought yesterday. I need to figureout how to histogram this with wideband. I can tune with hp tuners using the lc-2 and histogram but having a hard time with this.

  4. #4
    Fuel Injected!
    Join Date
    Oct 2014
    Age
    34
    Posts
    44
    I didnt mess with the inj tables at all. I think someone messed with this car, I tried downloading some other stock files but when I compare the only difference was on my first 3 map columns on the reg ve mine was 16.5 less then a camaro z28
    Last edited by suffolkauto01; 10-14-2014 at 06:24 AM.

  5. #5
    Fuel Injected! steveo's Avatar
    Join Date
    Aug 2013
    Posts
    2,378
    i'd be more interested in just seeing a closed loop log than you getting your wideband working at this point. i really doubt it's idling at 18:1 after jacking up all your fueling

  6. #6

  7. #7
    Fuel Injected!
    Join Date
    Oct 2014
    Age
    34
    Posts
    44
    I sub 2 to maf tables. I put inj at 24 still rich was fine in begining closed loop then went rich. I think there is a 320lph fuel pump in there but with pressure reg shouldnt matter that much right? here is data master run

  8. #8
    Fuel Injected! steveo's Avatar
    Join Date
    Aug 2013
    Posts
    2,378
    that's correct. it shouldn't be very rich with the stock maf tables; i would reccommend that you stop playing with the maf tables, put it back to stock, and definitely stop just adding whole numbers. they need to be scaled by multiplying (and carefully). you have another problem. are these the stock injectors?

  9. #9
    Fuel Injected! steveo's Avatar
    Join Date
    Aug 2013
    Posts
    2,378
    buddy i looked at your log.

    you have a major blm split (meaning one bank is reading way unbalanced from the other one). this is probably NOT a tuning issue, so stop tuning right away and just change it back to stock. you may just end up masking the actual problem by "tuning around it".

    this problem persists throughout the rpm range meaning it's a fairly big issue, not just some tiny exhaust leak or something. only one bank is reading rich.

    your o2 sensors are switching ok which means its probably not an o2 sensor issue, but not a garuntee of that. did you replace both o2 sensors or just one?

    possible causes i'd look at first (but im sure there are others);

    - a decent sized exhaust leak probably on the right hand side
    - leaky injector probably on the left hand side
    - clogged injector on the right hand side
    - intake manifold gasket leak or other vacuum leak
    - fouled spark plugs or dead plug wire causing consistent misfire
    - valvetrain issue, broken spring, tight rocker.. (although your MAP doesn't seem to reflect that, it's worth pulling the valve covers and having a look...)

    tell me what you try i'll continue to help you

  10. #10
    Fuel Injected!
    Join Date
    Oct 2014
    Age
    34
    Posts
    44
    New tune deco plugs exhaust no leak. No cat, 36000 miles

  11. #11

  12. #12
    Fuel Injected!
    Join Date
    Oct 2014
    Age
    34
    Posts
    44
    Ill pull plugs and let you know thank you

  13. #13
    Fuel Injected!
    Join Date
    Oct 2014
    Age
    34
    Posts
    44
    scoped out injectors good this car is making me CRAZY look at datamaster file I thing upstream 02 no good I have from open loop into closed

  14. #14
    Fuel Injected!
    Join Date
    Oct 2014
    Age
    34
    Posts
    44
    All plugs great btw.

  15. #15
    Fuel Injected!
    Join Date
    Oct 2014
    Age
    34
    Posts
    44
    All plugs great no vacuum leaks smoked out btw.

Similar Threads

  1. $8c 1995 4.3 cpi?
    By dave w in forum GM EFI Systems
    Replies: 36
    Last Post: 09-15-2015, 03:45 AM
  2. 1995 TPI
    By jaros44sr in forum Introductions
    Replies: 12
    Last Post: 01-15-2014, 06:46 PM
  3. Speedometer Calibration for 1995 Z28
    By 95Lt1 in forum GM EFI Systems
    Replies: 3
    Last Post: 01-01-2014, 09:23 PM
  4. 1995 yj wrangler
    By tudy in forum GM EFI Systems
    Replies: 4
    Last Post: 04-11-2013, 12:27 PM
  5. newbie for 1995 GM 5.7l tb1 troubleshooting
    By Ranman in forum GM EFI Systems
    Replies: 11
    Last Post: 03-13-2012, 02:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •