Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Results 1 to 5 of 5

Thread: random sudden lean during acceleration

  1. #1
    Fuel Injected!
    Join Date
    Jan 2013
    Location
    tennessee
    Posts
    39

    random sudden lean during acceleration

    On the way home from work as i was turning on to the last street before home, I heard a tink from under the hood. It was pouring down rain and very windy and i may have picked up a rock. But the point is, after that the truck started pegging lean on the wideband. When i blip the throttle it jumps back up to around 13-15 AFR. I just took the regulator apart and the diaphragm was fine. Its also has a new fuel pump. During idle its fine, its always had a slight hesitation during idle but its more pronounced now. I had the hesitation almost completely gone after uping the off idle spark table a couple degrees around the low rpm areas. My fuel pressure gauge broke so i will update with that when i get one to work but i see no reason for it to be low since its been running fine. Now im not sure if this is a fuel issue or electrical now.

  2. #2
    Fuel Injected! steveo's Avatar
    Join Date
    Aug 2013
    Posts
    2,447
    if you think about it, perhaps that 'tink' was an exhaust stud busting off, that would explain those readings.... i'd check that first.

    until you check pressure and all that, don't focus on fueling too much.

    keep in mind if a cylinder is just pumping air and not exhaust gasses, it'll look lean on a wideband.. so make sure a plug wire didnt burn or come loose or whatever.

    hell even a busted valve spring can show up as 'lean mixture' to an o2 sensor.

  3. #3
    Electronic Ignition!
    Join Date
    Aug 2014
    Age
    42
    Posts
    13
    Are you running a VSS and/or connected to the P/N switch?

    I had a TPI car that would do that every once in a while right after deceleration and then picking back up on acceleration after a left or right hand turn.

  4. #4
    Fuel Injected!
    Join Date
    Jan 2013
    Location
    tennessee
    Posts
    39
    I should have added the truck responds to what the wideband is showing. It pegs like deceleration fuel cut off only im pressing the throttle and it almost dies when it shows lean. When i give it a blip the rpms come back up. its also idling around 14-16 afr when before it would be around 13-14.

    the vehicle is a 91 s10 with a 350 in it. the wiring is the same as factory except i made a adapter harness for a 7427 ECM. its been running great until last night. Iv tried googleing the issue but egr always comes up as the issue and im running no emissions with a simple eddy intake for the vortec heads.

    after i get it back together ill try to get a datalog to see if that helps.

  5. #5
    Fuel Injected!
    Join Date
    Jan 2013
    Location
    tennessee
    Posts
    39
    Well to update, it seems as if were all better now. I pulled the top part of the tbi off to get to the regulator and changed the diaphragm. The one i pulled out looked fine but i had a new one so i threw that in and made a new gasket for that top piece. While it was cool i checked the plugs and they looked fine so i fired it up and took it for a drive. It runs and drives like normal and has yet to act up so who knows.

Similar Threads

  1. Intermittent Acceleration Issue - TunerPro file attached
    By az79k5project in forum GM EFI Systems
    Replies: 1
    Last Post: 07-27-2014, 07:07 AM
  2. AUJP $8D - Acceleration Enrichment Documented
    By 84Elky in forum GM EFI Systems
    Replies: 1
    Last Post: 03-10-2014, 09:45 AM
  3. Random TCC unlock caused by $EE LT1 PCM - any help?
    By sherlock9c1 in forum GM EFI Systems
    Replies: 3
    Last Post: 07-10-2013, 08:22 PM
  4. A few random $8D questions
    By JeepsAndGuns in forum GM EFI Systems
    Replies: 43
    Last Post: 02-26-2013, 04:35 PM
  5. acceleration enrichment on off at idle
    By Aholt91ss in forum GM EFI Systems
    Replies: 61
    Last Post: 02-16-2013, 08:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •