Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Page 1 of 3 123 LastLast
Results 1 to 15 of 43

Thread: TBI issues

  1. #1
    Fuel Injected!
    Join Date
    Jan 2013
    Age
    24
    Posts
    91

    TBI issues

    so driving to class yesterday my truck just gave up started stumbling all over itself, i turned around headed back home grabbed my grnadfathers car and went to school, i decided at that point since the engine needed resealing that id pull it reseal it and do nothig else so i did exactly that but its still stimbling, everything is properly attached adn its doing the exact same thing, not that i hoped itd fix it but i was wishing greatly tht it might cause sometimes odd things happen. anyhwo i cant figure it out and with my laptop no longer recognizing my ALDL i have to do this manually.

    symptoms, runs great after start up until you go to a complete stop, rpms start to drop and it sometimes stalls, well 90 percent of the time it does unless you put it in nuetral at a stop. after putting it back in drive or taking off from a stop it stumbles, it doesnt miss it just seems like nothing is advancing the timing, itll shift into second and it sticks at an rpm and then slowly struggles to regain itself. and it does that throughout each gear, but i can never get full power out of the thing, im stuck at around 45 mph while driving i cant get it to move any faster.

  2. #2
    EFI GearHead ! EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    57
    Posts
    10,477
    You can check timing with a timing light to see if it is advancing.

    Fuel pressure is another manual check.

    Vacuum leaks and EGR not closing are a couple more.

    Is the CEL on? What codes?

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  3. #3
    Fuel Injected!
    Join Date
    Jan 2013
    Age
    24
    Posts
    91
    timing at 0 degrees, fuel pressure is good, egr deleted, no vacuum leaks, i almost doused my engine in starting fluid trying to find any vacuum leaks. check engine light is on but its always one i presume i should find a obd1 scanner

  4. #4
    EFI GearHead ! EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    57
    Posts
    10,477
    Timing is set to 0*, but is it advancing when you check with timing light now?

    Fuel pressure is good... good for what? What is the pressure?

    CEL is on? But it has always been on? So there has always been a problem... what is the problem?

    Starting fluid used to be a good medium to check for vacuum leaks but do to EPA changes in content it is now as worthless as tits on a bull. Use a propane torch similar to what is used to solder copper pipes. It is also safer and more precise to point at area of leak.

    OBDI scanner could help. But finding what the issue is with your cable and getting it to record a data log so we can all see and help is a better choice.

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  5. #5
    Fuel Injected!
    Join Date
    Jan 2013
    Age
    24
    Posts
    91
    i think the laptop is just slow and ornery lol i wish i could figure that out but ive had no luck, ive done everything in my will to get the cable and computer to recognize one another.

    fuel pressure is right around 13 psi

    when checking timing with a lighth it stays at ) at idle if you rev it the spark advances and such.

    Could EGR be the issue with the light? and are you saying stuff an unlight propane torch down there and hope something idles up or so?

  6. #6
    Fuel Injected!
    Join Date
    Feb 2013
    Posts
    452
    Is the IAC moving?

  7. #7
    EFI GearHead ! EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    57
    Posts
    10,477
    Quote Originally Posted by Tylerz281500 View Post

    Could EGR be the issue with the light?
    Yes

    Quote Originally Posted by Tylerz281500 View Post

    and are you saying stuff an unlight propane torch down there and hope something idles up or so?
    Yes, anywhere there is a vacuum leak found it will suck in propane and idle will smooth or raise.

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  8. #8
    Fuel Injected!
    Join Date
    Oct 2013
    Posts
    782
    Since you say the timing advances I'm assuming you're checking it without disconnecting the advance wire?? If you are, the timing should not read 0* at idle.

    How about you jumper the ALDL pins and count the flashes and get the codes.

  9. #9
    EFI GearHead ! EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    57
    Posts
    10,477
    Quote Originally Posted by lionelhutz View Post
    How about you jumper the ALDL pins and count the flashes and get the codes.
    Does that work on 93-94 $E6 type PCM?

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  10. #10
    Fuel Injected!
    Join Date
    Oct 2013
    Posts
    782
    Quote Originally Posted by EagleMark View Post
    Does that work on 93-94 $E6 type PCM?
    No idea. It's not terribly difficult to go to a forum for the vehicle which would use that PCM and find out.

  11. #11
    Fuel Injected! jim_in_dorris's Avatar
    Join Date
    Dec 2011
    Posts
    771
    Yes jumpering the ALDL pins will work on that PCM.
    Square body stepsides forever!!!

  12. #12
    Fuel Injected!
    Join Date
    Sep 2013
    Location
    Tulsa, Ok
    Age
    41
    Posts
    448
    Tyler, I had a similar issue found to be a broken fpr spring. just an idea to mull over. easy enough to pull the injector pod and inspect.
    Here's my post http://www.gearhead-efi.com/Fuel-Inj...is-picture-out
    If it don't fit force it, if it don't force fit f&%@ it!

  13. #13
    Fuel Injected!
    Join Date
    Jan 2013
    Age
    24
    Posts
    91
    what pins am i jumping on the aldl? also the wire wasnot detached as you stated, so what should it be reading?

    i took it to a trusted shop and sensors and everything checks out. whats the possibility of the computer taking a crap? as i remember the 8625 have the built in esc if its timing related then that may be the cause. and the issues are only present under load after the vehicle has come to a complete stop. if i never stopped and kept going itd do fine.

    edit: i can rev the piss out of it in nuetral and park and it keeps up just fine. and i know i went throght eh whole pod and base and redid everything.
    Last edited by Tylerz281500; 12-08-2013 at 11:57 AM.

  14. #14
    Fuel Injected!
    Join Date
    Jan 2013
    Age
    24
    Posts
    91
    anyone have any ideas? i found that oriellys has a reman unit but i dont know if its a BDJY unit or if that even matters?

  15. #15
    Electronic Ignition!
    Join Date
    Sep 2013
    Location
    TX
    Posts
    10
    Have you check the condition of distributor? Maybe stator coil? Look to see if the distributor has any play.

Similar Threads

  1. insert image issues?
    By xtreamvette69 in forum GearHead EFI Forum Support
    Replies: 6
    Last Post: 03-16-2014, 09:25 PM
  2. 95 K3500 (454) tuning issues
    By 454/4X4 in forum GM EFI Systems
    Replies: 45
    Last Post: 07-28-2013, 09:42 PM
  3. Search issues
    By 1project2many in forum GearHead EFI Forum Support
    Replies: 10
    Last Post: 03-25-2013, 07:08 PM
  4. TPI issues
    By webbs in forum GM EFI Systems
    Replies: 5
    Last Post: 02-01-2013, 03:18 PM
  5. Issues with TBI 7747 tune
    By srobertsfsj in forum GM EFI Systems
    Replies: 40
    Last Post: 04-13-2012, 10:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •