Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Results 1 to 11 of 11

Thread: '7730 ECM - Pin F8 Question

  1. #1
    Fuel Injected! 84Elky's Avatar
    Join Date
    Jul 2012
    Location
    Montgomery, AL
    Posts
    87

    '7730 ECM - Pin F8 Question

    Thought it best to post this separately since a different issue from prior post dealing with Fan 1 Pin E8 (here: http://www.gearhead-efi.com/Fuel-Inj...or-Fan-1-Relay)

    Hooked up a relay wrong and passed 12-13v to Pin F8 for a few seconds. Now when the Fan 2 enable temperature is reached, the voltage when probing Pin F8 is all over the map from 13+v to near zero, pulsing 3-4 times a second. If the wire from F8 is plugged into the relay, can feel the relay clicking 3-4 times a second. The fan runs, but not at full speed apparently because of the varying voltage it's being supplied.

    Have I fried my ECM? Any other ideas? Thanks!

  2. #2
    Super Moderator
    Join Date
    Mar 2011
    Location
    Camden, MI
    Age
    29
    Posts
    3,026
    probably. i'm not sure how tolerant the quad drivers are of that scenario, but with the voltages you're seeing when it should be either all or nothing, something is damaged.
    1995 Chevrolet Monte Carlo LS 3100 + 4T60E


  3. #3
    Fuel Injected! 84Elky's Avatar
    Join Date
    Jul 2012
    Location
    Montgomery, AL
    Posts
    87
    Quote Originally Posted by RobertISaar View Post
    probably. i'm not sure how tolerant the quad drivers are of that scenario, but with the voltages you're seeing when it should be either all or nothing, something is damaged.
    Unfortunately agree. Just placed order for replacement ECM. Just seems strange that 12-13v on a Pin that carries that voltage until it goes low would be damaged by it, but it is what it is. The replacement ECM will tell. Thanks.

  4. #4
    Super Moderator
    Join Date
    Mar 2011
    Location
    Camden, MI
    Age
    29
    Posts
    3,026
    it doesn't conduct when not in use though..... it's an open circuit until commanded on.

    i get the feeling that there is a diode inside the quad driver that would conduct when the quad driver is used as a source rather than a sink.

    i've "abused" the quad drivers on my 9396 on the bench.... i've given it up to 2 or maybe 2.5 amps of load to deal with for short periods of time, and they appear to have survived and function normally still.
    1995 Chevrolet Monte Carlo LS 3100 + 4T60E


  5. #5
    Super Moderator Six_Shooter's Avatar
    Join Date
    Feb 2011
    Posts
    2,884
    There's a difference between the 12V seen through the coil of the relay and applying 12V directly to the pin.

    When the 12V signal is passed through a coil, there is an impedance to it, and that will reduce the potential current. Usually the current in this case would be close to zero, where as when 12V is directly applied to the pin there is no current limiting.
    The man who says something is impossible, is usually interrupted by the man doing it.

  6. #6
    Super Moderator
    Join Date
    Mar 2011
    Location
    Camden, MI
    Age
    29
    Posts
    3,026
    hmm...... should also consider that if any of the other outputs on that driver were active at the same time, you would have unlimited +12V and ground being connected to the same circuit from within the quad driver itself...

    i imagine some magic smoke were released.
    1995 Chevrolet Monte Carlo LS 3100 + 4T60E


  7. #7
    Fuel Injected! 84Elky's Avatar
    Join Date
    Jul 2012
    Location
    Montgomery, AL
    Posts
    87
    Quote Originally Posted by RobertISaar View Post
    hmm...... should also consider that if any of the other outputs on that driver were active at the same time, you would have unlimited +12V and ground being connected to the same circuit from within the quad driver itself...

    i imagine some magic smoke were released.
    And that is what likely occurred!

  8. #8
    EFI GearHead ! EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    58
    Posts
    10,477
    Quote Originally Posted by RobertISaar View Post
    i imagine some magic smoke were released.
    You can fix that!
    Attached Images Attached Images

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  9. #9
    Super Moderator
    Join Date
    Mar 2011
    Location
    Camden, MI
    Age
    29
    Posts
    3,026
    of course it's made by Lucas.
    1995 Chevrolet Monte Carlo LS 3100 + 4T60E


  10. #10
    Fuel Injected! 84Elky's Avatar
    Join Date
    Jul 2012
    Location
    Montgomery, AL
    Posts
    87
    Quote Originally Posted by EagleMark View Post
    You can fix that!
    At this point, will need 2 bottles of it!

    Smoke.jpg

  11. #11
    Fuel Injected! 84Elky's Avatar
    Join Date
    Jul 2012
    Location
    Montgomery, AL
    Posts
    87
    This issue was resolved here (see Post #4):
    http://www.gearhead-efi.com/Fuel-Inj...nd-7730-Pin-F8

Similar Threads

  1. 7730 A/C clutch control
    By 34blazer in forum GM EFI Systems
    Replies: 19
    Last Post: 09-24-2013, 05:15 PM
  2. 7730 Pin E8 Question for Fan 1 Relay
    By 84Elky in forum GM EFI Systems
    Replies: 11
    Last Post: 09-23-2013, 11:46 AM
  3. Help with 7730 on 305 SBC TPI (Speed Density)
    By RadioTechMan in forum GM EFI Systems
    Replies: 7
    Last Post: 08-16-2013, 03:32 AM
  4. 7730 - Rich on Cranking/Startup
    By bnevets27 in forum GM EFI Systems
    Replies: 13
    Last Post: 05-13-2013, 10:34 PM
  5. WTB 7730/7727 V8 memcal
    By JeepsAndGuns in forum Buy - Sell - Trade - Wanted
    Replies: 11
    Last Post: 02-03-2013, 11:02 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •