Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Page 21 of 73 FirstFirst ... 1116171819202122232425263171 ... LastLast
Results 301 to 315 of 1095

Thread: ALDLdroid

  1. #301
    Fuel Injected! -=Jeff=-'s Avatar
    Join Date
    Jun 2013
    Location
    Chicago Suburbs
    Age
    46
    Posts
    134
    Cool deal,

    If you want me to try something before you load it to play, my email is vettxtc@gmail.com

    As a sanity check I verified the cable and adx work with tunerpro and are just fine

  2. #302
    Fuel Injected!
    Join Date
    Oct 2013
    Location
    Oklahoma
    Age
    54
    Posts
    48
    I've been using ALDLdroid for a week or so and I'm real happy!

    I'm using $A1 code in my '59 Jaguar and connecting via bluetooth to a 7" Sero7 Pro tablet (got mine from Walmart for $150). There are lots of Android tablets and phones out there for less than $100. If you've going to connect with a cable, make sure your phone/tablet supports "OTG" (that means On The Go) and you might need to actually try it to confirm. Oh, and you might need an OTG adapter cable that lets you plug your USB to ALDL cable in. I couldn't find one locally so had to order one, Amazon, E-Bay, etc. Bluetooth should work on any device when using a Bluetooth ALDL adapter.

    These tables/phones have gotten cheap enough and come in such a variety of sizes (4" to 12" or so) that's there's no reason you can't "permanently" install one in your vehicle, maybe on the sun visor or wherever.

    About the only issue you could encounter is an ADX file that has stuff in it that ALDLdroid doesn't understand yet, that's those crashes described above. Fortunately it's an easy fix, send the crash report to 3400tZ so he can add the parameters in your ADX (he shows you how in a previous post). Filling out the description field of the crash report, what you were doing when it crashed, is always helpful.

    I've built an number of PC and Arduino based ALDL digital dash/loggers over the years trying to get something portable and affordable with the intent of installing it permanently in my cars. I never quite made one that was exactly what I wanted. ALDLdroid with a Android device is exactly what I'd been trying to accomplish.

    Thanks 3400tZ!!!!
    Last edited by mikew; 12-01-2013 at 03:35 PM.

  3. #303
    Fuel Injected!
    Join Date
    Apr 2013
    Posts
    485
    Jeff, I sent you a chat invite if that works for you, otherwise I can send a APK later.

    Mike, thanks for the great review! :)

  4. #304
    Fuel Injected!
    Join Date
    Apr 2012
    Age
    71
    Posts
    79
    It crashes while connecting after loading the "EE_auto.adx" file. Just sent a report.

  5. #305
    Fuel Injected!
    Join Date
    Apr 2013
    Posts
    485
    Gary, I've found the issue and fixing it right now. Jeff issue is half fixed as well, we're working on the second part. I will have another build on Play tonight fixing those issues.

    I'm thinking about unpublished the app from Play. Not too impressed with all the crashes reports :/

  6. #306
    Fuel Injected!
    Join Date
    Apr 2013
    Posts
    485
    I've unpublished the app for now. Will try to fix all the known problems first and maybe publish it again at some point :P There is no impact for people that already bought it and I'm now fixing all the issues.
    Last edited by 3400tZ; 12-01-2013 at 04:13 PM.

  7. #307
    Fuel Injected!
    Join Date
    Oct 2013
    Location
    Oklahoma
    Age
    54
    Posts
    48
    I think the only way you'll get all of those unknown parameters hiding in ADX files programed into ALDLdroid is by having people use it and report their issues.

    And I think the people who are tuning their own injection fully understand that nothing is perfect the first time, if it was, they wouldn't be tuning their injection and need tools like ALDLdroid, right?

    I say keep it at the Play Store, this initial batch of problem reports will pass quickly.

    Keep up the good work!

  8. #308
    EFI GearHead ! EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    59
    Posts
    10,477
    I agree, put it back!

    What ADX is Jeff having issues with? It may be one that has much more complcated values then all others.

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  9. #309
    Fuel Injected!
    Join Date
    Apr 2013
    Posts
    485
    Ok ok, it's back! (realized it would be a pain to update people without it being on Play as well :P).

    For Jeff, it seems to be issue with the silent commands that are sent on connect. He's getting good data, but like 4 data set out of 5 gets a checksum mismatch because there is some junk bytes inserted at random positions :/ We're on it right now!

  10. #310
    Fuel Injected! -=Jeff=-'s Avatar
    Join Date
    Jun 2013
    Location
    Chicago Suburbs
    Age
    46
    Posts
    134
    We Got IT!!!!! The program is KILLER!!! 3400tZ, is working on what was found and was my issue and potentially others due to the way you can set-up commands, we came up with a work around for me and it works, He is now fixing the program so the workaround is not needed. Needless to say I am so impressed with it I will be telling all my friends, seriously, I have wanted an app like this for so long and I am very impressed with the program. Unfortunately is it colder here now and I will not be able to truly use it until spring, but for testing it in the garage it will work out nicely, this will be a nice replacement for my laptop in the car, I also have an app radio with an android Stick, so I can install this in the car and use it as needed.

    I tested it with USB, on the 2013 Nexus 7 with Kit Kat and it works very well..

    VERY HAPPY

  11. #311
    EFI GearHead ! EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    59
    Posts
    10,477
    Quote Originally Posted by 3400tZ View Post
    For Jeff, it seems to be issue with the silent commands that are sent on connect.
    Very rare option, so when it's fixed all 3-4 ADX files that have it are done!

    Don't expect them all to be like this, it's a rare one.

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  12. #312
    Fuel Injected! -=Jeff=-'s Avatar
    Join Date
    Jun 2013
    Location
    Chicago Suburbs
    Age
    46
    Posts
    134
    Quote Originally Posted by EagleMark View Post
    Very rare option, so when it's fixed all 3-4 ADX files that have it are done!

    Don't expect them all to be like this, it's a rare one.
    Yes but one of the fixes could happen with any adx, depending on how it is set-up int he commands, He is working on it and I am helping test it

  13. #313
    Fuel Injected!
    Join Date
    Apr 2013
    Posts
    485
    We got it all figured out with Jeff. I guess now it is Gary's turn. Gary, I've uploaded version 0.16 on Google Play, it should show up in an hour or so. Once you've updated, it shouldn't crash anymore. Hopefully it will connect and everything will be fine but let me know if you're having issues.

  14. #314
    Fuel Injected!
    Join Date
    Apr 2012
    Age
    71
    Posts
    79
    What do you mean by "silent" commands? Is that the "disable" command that tells the pcm to shutup If so, are we sure the silence command is working? The "random" bytes may be the normal pcm housekeeping (mph, rpm, and pcm address) that always are sent if the silence mode isn't activated. The bus should stay quiet for about 3 seconds if it has worked and then indefinitely if data requests are sent before that time.

    By the way, I have no adapter yet except part of one (B/T part). That way I can see what the output looks like so I can try to build a real cheap ALDL adapter. Shouldn't take more than an hour is it's feasible. Then I can let you know how it works on the LT1 pcm setup.
    Last edited by GaryDoug; 12-01-2013 at 07:08 PM.

  15. #315
    Fuel Injected!
    Join Date
    Apr 2013
    Posts
    485
    Quote Originally Posted by GaryDoug View Post
    What do you mean by "silent" commands? Is that the "disable" command that tells the pcm to shutup If so, are we sure the silence command is working? The "random" bytes may be the normal pcm housekeeping (mph, rpm, and pcm address) that always are sent if the silence mode isn't activated. The bus should stay quiet for about 3 seconds if it has worked and then indefinitely if data requests are sent before that time.
    It turned out that the silence commands (the commands to silence the ABS and CCM) weren't working because I was missing the checksum byte. It was spitting out random bytes in the monitor command response. It works awesome now from what he's saying :)
    Last edited by 3400tZ; 12-01-2013 at 07:07 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •