Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Results 1 to 4 of 4

Thread: $0D MPFI, base timing and injector timing

  1. #1
    Fuel Injected! JeepsAndGuns's Avatar
    Join Date
    Sep 2011
    Location
    alabama
    Age
    35
    Posts
    1,672

    $0D MPFI, base timing and injector timing

    Well, ever since I converted to MPFI, I have been battleing a problem with my AFR all over the place. Some of you may remember my thread ( http://www.gearhead-efi.com/Fuel-Inj...-created-equal )that went on forever. I tried a different o2 sensor, tried chaning different things, I added, enabled, and tuned a MAT sensor, which helped a lot, but AFR was still all over the place.
    I had figured it had to be the fact my wideband was in the right down pipe, and my NB was in the left down pipe. So I recently installed some headers and moved the WB to the left down pipe and placed it a couple inches in front of, and slightly offset from the NB. Well no major changes, AFR still all over the place. So I decided to try something. I remembered seeing in several posts, Mark talked about always having base timing set to zero, because injector timing is based off the DRP's.
    I have had my base timing set at 10* ever since I swapped to fuel injection. Reason being my engine would barely run at 0* timing, definately would not be driveable. So I followed advise from a couple places and set it to 10* so if I ever went into limp home mode, I could drive it. Everything worked great with TBI, it wasnt untill I went to MPFI that I started having problems.
    Anyways, today I drive it till its warm, and reset my base timing to 0*. It just barely ran enough to set it. I changed the bin to match and burnt a new chip. Take it for a spin and wow, now my AFR is now where its supposed to be, only swings what is probably normal. It actually seems to run just a little bit smoother too. Also, my AE was now going lean if I hit the gas, so I had to spend some time and add a little AE.
    I'm guessing with TBI, the injectors were far enough away from the intake valves for it to not really effect things, but with MPFI and the injectors being much closer to the valves, it was enough to throw things off?
    79 Jeep Cherokee, AMC 401, T-18 manual trans, hydroboost, 16197427 MPFI system---the toy

    93 Jeep YJ Wrangler, 4.0L, 5 speed, 8.8 rear, homebrew hub conversion and big brakes, hydroboost, 2.5in OME lift, 31x10.50's---the daily driver

    99 Jeep WJ Grand Cherokee limited, 4.0L, auto, 2wd, leather and power everything, 99% stock---the long distance highway ride.

  2. #2
    EFI GearHead ! EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    58
    Posts
    10,477
    That's some really good testing and feedback!

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  3. #3
    Super Moderator
    Join Date
    Mar 2011
    Location
    Camden, MI
    Age
    29
    Posts
    3,026
    i don't know if this is a 7427/TBI ECM specific issue, but being MPFI, it really shouldn't matter, especially if in double-fire mode.
    1995 Chevrolet Monte Carlo LS 3100 + 4T60E


  4. #4
    Fuel Injected! JeepsAndGuns's Avatar
    Join Date
    Sep 2011
    Location
    alabama
    Age
    35
    Posts
    1,672
    I'm not sure either. I just know it runs better and AFR is not all over the place like it used to be. So it has definately changed something.
    79 Jeep Cherokee, AMC 401, T-18 manual trans, hydroboost, 16197427 MPFI system---the toy

    93 Jeep YJ Wrangler, 4.0L, 5 speed, 8.8 rear, homebrew hub conversion and big brakes, hydroboost, 2.5in OME lift, 31x10.50's---the daily driver

    99 Jeep WJ Grand Cherokee limited, 4.0L, auto, 2wd, leather and power everything, 99% stock---the long distance highway ride.

Similar Threads

  1. $58 timing with DIS
    By Six_Shooter in forum GM EFI Systems
    Replies: 24
    Last Post: 08-07-2013, 11:04 PM
  2. PROPER WAY TO SET UP TIMING IN CHIP AND CAR?
    By xtreamvette69 in forum GM EFI Systems
    Replies: 4
    Last Post: 08-06-2013, 07:51 PM
  3. Setting base timing for performance cam
    By srgould41 in forum GM EFI Systems
    Replies: 32
    Last Post: 04-27-2013, 12:33 PM
  4. Base timing for TBI-HEI with .060 spark plugs
    By helo in forum GM EFI Systems
    Replies: 5
    Last Post: 02-05-2013, 10:58 AM
  5. Carb'd 350 timing question
    By jim_in_dorris in forum Gear Heads
    Replies: 15
    Last Post: 07-15-2012, 11:23 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •