Results 1 to 8 of 8

Thread: AE clamp Flag in $0D ?" and no fuel in decel?

  1. #1
    RIP EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    62
    Posts
    10,477

    AE clamp Flag in $0D ?" and no fuel in decel?

    What's the AE Clamp Flag in $0D data indicate? Saw it chasing a problem. Seems to come on when fueling is trying to recover...

    Also have no fuel on deceleration? No DFCO flag, no Decel Enlean Flag, both are disabled anyway, enabled and still have no fuel in deceleration? Well none that the wide band is showing? Deceleration pegs the WB lean and causes some bucking when AFR comes back on data...

    Running Open Loop. $0D 383 ci Ram Jet MPFI etc...

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  2. #2
    Fuel Injected!
    Join Date
    Feb 2013
    Location
    Euless, TX
    Posts
    2,093
    Quote Originally Posted by EagleMark View Post
    What's the AE Clamp Flag in $0D data indicate? Saw it chasing a problem. Seems to come on when fueling is trying to recover...

    Also have no fuel on deceleration? No DFCO flag, no Decel Enlean Flag, both are disabled anyway, enabled and still have no fuel in deceleration? Well none that the wide band is showing? Deceleration pegs the WB lean and causes some bucking when AFR comes back on data...

    Running Open Loop. $0D 383 ci Ram Jet MPFI etc...
    If memory serves me correctly there is a time delay on $0D scaled in reference pulses between the time that DFCO times out and refuel begins. Its been a while since I had the Hack opened in front of me though. Generally speaking AE is added to refuel the engine after DFCO. If the code is "clamping" the AE, its not delivering fuel. I am sure there was some emissions reason for it. What is the pulsewidth when this happens?? I seem to remember my pulsewidth on PFI $0D spiking slightly after DFCO, before returning to normal coasting idle pulsewidth. I also seem to remember being able to adjust the commanded timing advance in DFCO. -6* sticks out in my mind, not sure why.
    Last edited by Fast355; 04-21-2013 at 06:53 AM.

  3. #3
    RIP EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    62
    Posts
    10,477
    AFR = Orange
    Black = Lambda
    Green = Desired AFR
    Pink = MAP kpa
    Orange = TPS %
    Other Black = BPW

    Well here's what it looks like. Running good, drives good, then here is a spot without complete 0% TPS, AFR goes total lean, no DFCO flag, No Decel Enlean flag.



    Then when it tries to recover it get's worse, the AE clamp flag is coming on at bottom V of AFR Orange trying to recover, then AFR goes back up lean, then a yo yo effect... this picture is literally the next frames of first.
    Attached Images Attached Images

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  4. #4
    Fuel Injected! gregs78cam's Avatar
    Join Date
    May 2011
    Location
    N. Idaho
    Posts
    767
    Nevermind, you added data.

    Spiking orange is AFR, and Purple is Lambda, right?

    You aren't in DFCO as you still have almost 1ms Injector PW showing up. I would say it looks like the VE table is really lean in that MAP/RPM.
    Last edited by gregs78cam; 04-21-2013 at 07:09 AM.
    1978 Camaro Type LT, 383, Dual TBI, '7427, 4L80E
    1981 Camaro Z-28 Clone, T-Tops, 350/TH350
    1981 Camaro Berlinetta, V-6, 3spd
    1974 Chevy/GMC Truck, '90 TBI 350, '7427, TH350, NP203, 6" lift, 35s

  5. #5
    RIP EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    62
    Posts
    10,477
    During the super high AFR event...

    Wide band voltage 4.82
    Injector BPW .81
    Injector Duty Cycle 6.54

    No PE, DE, DFCO, ENlean, PE, AE etc... I've looked for hours trying to find any!

    Tried so many things with DFCO including adjusting the wrong way and same results... I'll keep looking for something DFCO related, but like I said no flag either?

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  6. #6
    Fuel Injected!
    Join Date
    Feb 2013
    Location
    Euless, TX
    Posts
    2,093
    Quote Originally Posted by EagleMark View Post
    During the super high AFR event...

    Wide band voltage 4.82
    Injector BPW .81
    Injector Duty Cycle 6.54

    No PE, DE, DFCO, ENlean, PE, AE etc... I've looked for hours trying to find any!

    Tried so many things with DFCO including adjusting the wrong way and same results... I'll keep looking for something DFCO related, but like I said no flag either?
    What is the IAC doing while this is occuring?? Have you considered temporarily disabling the IAC and opening the throttle plate instead? I have had issues with IAC AE before.

    Any way to send me the datalog file and the approximate time frame this is occuring?

  7. #7
    RIP EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    62
    Posts
    10,477
    Looks like there may be an IAC issue and throttle blades need opening... I'll have to look more at log. This was set at idle and had about 20 counts warm idle. EDIT: Looked at idle an IAC is up to 40...

    During this event, IAC was 150 cruising, then went to 90 and stayed there. 10:00 in log, it happens all over but this is where pictures from above are. And only spot I can find where it happens at other then 0% TPS which made it stand out. TPS was 13.x% and dropped to 7.8% and still got this DFCO effect, that's way above TPS % for DFCO...
    Attached Files Attached Files

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  8. #8
    Fuel Injected!
    Join Date
    Feb 2013
    Location
    Euless, TX
    Posts
    2,093
    Any luck?
    Last edited by Fast355; 04-29-2013 at 05:53 AM.

Similar Threads

  1. Replies: 55
    Last Post: 11-13-2013, 03:55 PM
  2. Replies: 16
    Last Post: 02-28-2013, 06:38 AM
  3. Replies: 4
    Last Post: 07-10-2012, 08:38 AM
  4. 4L80E+decel lockup
    By gregs78cam in forum GM EFI Systems
    Replies: 1
    Last Post: 08-05-2011, 06:29 AM
  5. Plug readings by Bruce Plecan AKA "Grumpy" R.I.P. dedication
    By EagleMark in forum Fuel Injection Writeups Articles and How to New and Old
    Replies: 0
    Last Post: 03-20-2011, 09:14 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •