Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Results 1 to 4 of 4

Thread: Help! 90 Chevy Blazer starts runs dies?

  1. #1
    Electronic Ignition!
    Join Date
    Mar 2013
    Age
    43
    Posts
    13

    Help! 90 Chevy Blazer starts runs dies?

    Help! 90 Chevy Blazer starts runs dies? Has gas to throttle body and leaving the return line on the throttle body but the injectors slowly stop spraying after going from the start position to the run position? So soon after you let off the key from start position and the key goes to run position it dies just before you grab the shifter. watching the 2 two injectors and they spray really good while its running and then its like something tells the computer to stop spaying. Ive had the jumped to eliminate the possability of low voltage. I checked for Vacuum leaks and non were found. The check engine light isn't working at all either if that would tell us. check engine light worked yesturday. I think its pre injectors and post pump because it spays good when running. Any ideas?

  2. #2
    Electronic Ignition!
    Join Date
    Feb 2013
    Age
    53
    Posts
    14
    Here's a pic of the fuel pump relay on the firewall...
    fuel-relay.jpg

    The arrow is to the bypass connector. Connect this to 12V (fused w/ 1.5 amp) to bypass the relay and see if that fixes the problem. A new relay is around $15. Good luck!
    1989 Suburban 350, 1227747 / $42
    - Dana 60 Front w/ ARB Locker
    - 14 Bolt Full-Floating Rear w/ Detroit Locker
    - LT285/75R17 Toyo A/T II on 17x8 American Mohave
    - 4" Tuff Country HD Springs (Rear)
    - 3" Tuff Country HD Springs (Front)

  3. #3
    EFI GearHead ! EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    58
    Posts
    10,477
    That would not explain sudden loss of CEL?

    Quote Originally Posted by ChrisBama View Post
    The check engine light isn't working at all either if that would tell us. check engine light worked yesturday. I think its pre injectors and post pump because it spays good when running. Any ideas?
    Sounds like you blew a fuse, hopefully not a wire.

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  4. #4
    Electronic Ignition!
    Join Date
    Mar 2013
    Age
    43
    Posts
    13
    New Fuel pump and it runs good so far. The check engine light was working yesterday when I checked the fuel pressure so I think that was a fluke think? Thanks, Chris

Similar Threads

  1. 2002 blazer
    By mdj in forum TunerPro OBDII
    Replies: 1
    Last Post: 03-28-2013, 12:19 AM
  2. truck runs for 30 sec then dies help!!!!!!
    By lilhupper in forum GM EFI Systems
    Replies: 47
    Last Post: 03-24-2013, 04:50 PM
  3. Help! Truck dies after ~20 seconds
    By Xenon in forum GM EFI Systems
    Replies: 39
    Last Post: 02-28-2013, 11:17 PM
  4. Cant get Tunerpro RT to connect once engine starts
    By Fastmax32168 in forum TunerPro Tuning Talk
    Replies: 34
    Last Post: 10-25-2012, 12:19 PM
  5. 94 TBI Blazer cutting out
    By 96lt4c4 in forum GM EFI Systems
    Replies: 10
    Last Post: 08-09-2012, 12:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •