Bringing TBI and Multi Port Fuel Injection to a New Level.     EFI Conversions and Tuning! Seattle to Portland! E-mail Tuning Consultant!
Page 1 of 2 12 LastLast
Results 1 to 15 of 26

Thread: Ultra rich at cold start???

  1. #1
    Fuel Injected! jameslleary's Avatar
    Join Date
    Apr 2011
    Location
    Patterson, Ca
    Posts
    269

    Ultra rich at cold start???

    Hey guys,
    I am trying to help another Truck owner figure out a problem.
    truck is an 87 GM with a TBI 350. it has been rebuilt and bored .30 over. Cam is next step up from stock, Comp cam, ECM friendly.
    Problem is, he says its flooding on cold start, and after about 3 minutes, it starts to lean out, but is still a bit rich at warm idle. all sensors and ecm have been replaced 3 times to no joy.
    Still banging my head on this....any ideas?
    He hooked a vac gauge up, and while cold and flooding, the gauge bounces between 14 and 16 with a corresponding lope...gauge reads 17 at warm idle.

  2. #2
    Fuel Injected! jim_in_dorris's Avatar
    Join Date
    Dec 2011
    Posts
    802
    James, is the truck chipped? The reason I ask, is that 87 GM trucks for california only came with 305's. The bouncing vacuum when cold then clearing up when warm almost sounds like a problem with one of his valves not seating when cold. That's just a guess though. How many miles on the rebuild?
    Square body stepsides forever!!!

  3. #3
    EFI GearHead ! EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    58
    Posts
    10,477
    Good guess too! Something is wrong mechaniclly if vacuum reading is bouncing. Could be vacuum leak one cylinder as well...

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  4. #4
    Fuel Injected! jameslleary's Avatar
    Join Date
    Apr 2011
    Location
    Patterson, Ca
    Posts
    269
    Yeah, i have banged my head on all the mechanical stuff pretty good.
    He is in Ohio.
    There seems to be so many TBI systems running really rich and causing problems...even when the engines are replaced with factory units, and all AC Delco sensors, Delco ignition.
    The only thing that goes through my mind, and because he says its only flooding at cold start, would be the CTS, or the circuit for it. He claims that he has replaced all sensors multiple times.
    But then it settles into a normal idle after 3 minutes...albeit a little rich., per the engine analyzer between the eyes.

    BTW,
    according to GM literature, All engines were available in CA in 87.

  5. #5
    EFI GearHead ! EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    58
    Posts
    10,477
    Settling into normal idle at approx three minutes sounds like Closed Loop timer expired. New engines being this way could be no BLM learn at this point.

    But your buddys shaking vacuum reading is an issue.

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  6. #6
    Super Moderator dave w's Avatar
    Join Date
    Feb 2011
    Posts
    3,892
    Is there a data log of this happening?

    dave w

  7. #7
    Fuel Injected! jameslleary's Avatar
    Join Date
    Apr 2011
    Location
    Patterson, Ca
    Posts
    269
    Nope, no DL. Most folks dont have the stuff, but I try to push ALDL cables at least, but have not suggested it in this case yet.
    Mark, I was alarmed by the shaky vac too, but he says it settles to 17 after warming up.

  8. #8
    Super Moderator dave w's Avatar
    Join Date
    Feb 2011
    Posts
    3,892
    I'm thinking the lifters need to be re-adjusted? I'm thinking a lifter is failing to open a valve until warmed up? Several ways to re-adjust lifters, but I like the method that brings each cyliner to TDC of the compression stoke to make adjustments. I've seen were re-adjusting the lifters can actually make things worse, so I'm thinking only suggest lifter re-adjustment to a vehicle owner who has the skills / experience to the adjustment.

    dave w

  9. #9
    Fuel Injected! jameslleary's Avatar
    Join Date
    Apr 2011
    Location
    Patterson, Ca
    Posts
    269
    Yeah, I suggested the rocker re adjustment. This was happening before the rebuild too, I just found out. I will be Bald soon.

  10. #10
    Fuel Injected! jim_in_dorris's Avatar
    Join Date
    Dec 2011
    Posts
    802
    Try a compression check when engine is cold, My money is either a bad valve spring or a bad valve job.
    Square body stepsides forever!!!

  11. #11
    EFI GearHead ! EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    58
    Posts
    10,477
    Quote Originally Posted by jameslleary View Post
    Yeah, I suggested the rocker re adjustment. This was happening before the rebuild too, I just found out. I will be Bald soon.
    I hate when that happens...

    Quote Originally Posted by jim_in_dorris View Post
    Try a compression check when engine is cold, My money is either a bad valve spring or a bad valve job.
    or no valvejob?

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  12. #12
    Fuel Injected! jameslleary's Avatar
    Join Date
    Apr 2011
    Location
    Patterson, Ca
    Posts
    269
    Ok, Noted.
    He has been convinced to purchase an ALDL cable...he was ready to buy a new harness.

  13. #13
    Fuel Injected! jameslleary's Avatar
    Join Date
    Apr 2011
    Location
    Patterson, Ca
    Posts
    269
    ok, i have a few logs from him. Everything goes pig rich on the blm and int on cl, but in open loop, after start, the blm and int look normal, but the vac is very low, and the iac is wide open like a barn door, which i am banking that is the reason for the 8Hg vacuum.
    He is bored 30 over, comp cam, no part number, but jegs swore up and down it was a computer compatible cam.
    holly replacement throttle body. he says it was acting the same way before the rebuild.
    Attached Files Attached Files

  14. #14
    EFI GearHead ! EagleMark's Avatar
    Join Date
    Feb 2011
    Location
    North Idaho
    Age
    58
    Posts
    10,477
    BLM won't help CL.

    60 MAP at 800 idle?
    DTC 45, O2 rich?
    High IAC count I think is trying to keep it running but a quick 1/4 to 1/2 turn in will prove it.
    Diagnostic Mode Enabled isn't helping either, but he has issues your not going to find unless you get your hands on it. Start with everything...

    1990 Chevy Suburban 5.7L Auto ECM 1227747 $42!
    1998 Chevy Silverado 5.7L Vortec 0411 Swap to RoadRunner!
    -= =-

  15. #15
    Super Moderator dave w's Avatar
    Join Date
    Feb 2011
    Posts
    3,892
    Quote Originally Posted by jameslleary View Post
    holly replacement throttle body. he says it was acting the same way before the rebuild.
    Holley TBI have Adjustable Fuel Pressure Regulators? Try less fuel pressure. Was the Holley TBI on the engine before the rebuild?

    dave w

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •